Bug 814706 - osad.conf file need to loose an "s" either for "proto =" or "server_url ="
osad.conf file need to loose an "s" either for "proto =" or "server_url ="
Status: CLOSED NOTABUG
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.7
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-04-20 09:36 EDT by James Edwards
Modified: 2012-11-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 14:33:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Edwards 2012-04-20 09:36:23 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 James Edwards 2012-04-20 09:46:33 EDT
sorry I submitted to quickly..

I noticed upon adding the osad package 
there was a an extra "s" killing the configmanagment and osad communication with the server

see:
proto = https


see:

sever_url = %(proto)s://


if not manually edited 
this will be read as httpss://

once edited communication works fine. 

Either drop the "s" from https in the protocol entry 
or drop it lower in the server_url = entry..
Comment 2 Milan Zázrivec 2012-04-20 14:33:53 EDT
I'm sure the config file in its default form, i.e. with the directive

    server_url = %(proto)s://%(server_name)s%(server_handler)s

is all right.

The notation

    %(proto)s

doesn't mean that the proto directive will be expanded and the letter 's'
will be added afterwards. It means that the proto directive will be expanded
*as a string* period. No 's' added.

But to be actually able to make use of the server_url directive in osad.conf,
you need to manually add / define the server_name directive, otherwise
server_url won't be fully expanded and in the end will default to the server
you had specified in /etc/sysconfig/rhn/up2date.

I'm closing this with notabug, since there's nothing to fix here.

Note You need to log in before you can comment on or make changes to this bug.