Bug 814722 - koji build fails on el5-candidate (el6-candidate is ok)
koji build fails on el5-candidate (el6-candidate is ok)
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: koji (Show other bugs)
el5
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 10:33 EDT by Gratien D'haese
Modified: 2012-04-20 13:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 13:19:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gratien D'haese 2012-04-20 10:33:48 EDT
Description of problem:
$ koji build --arch=x86_64 --scratch el5-candidate RPM/SRPMS/rear-1.13.0-1.fc16.src.rpm
Uploading srpm: RPM/SRPMS/rear-1.13.0-1.fc16.src.rpm
[====================================] 100% 00:00:04 321.37 KiB  72.66 KiB/sec
Created task: 4008255
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4008255
Watching tasks (this may be safely interrupted)...
4008255 build (el5-candidate, rear-1.13.0-1.fc16.src.rpm): free
4008255 build (el5-candidate, rear-1.13.0-1.fc16.src.rpm): free -> open (x86-14.phx2.fedoraproject.org)
  4008256 buildArch (rear-1.13.0-1.fc16.src.rpm, x86_64): free
  4008256 buildArch (rear-1.13.0-1.fc16.src.rpm, x86_64): free -> open (x86-03.phx2.fedoraproject.org)
  4008256 buildArch (rear-1.13.0-1.fc16.src.rpm, x86_64): open (x86-03.phx2.fedoraproject.org) -> FAILED: BuildError: error building package (arch x86_64), mock exited with status 1; see build.log for more information
  0 free  1 open  0 done  1 failed
4008255 build (el5-candidate, rear-1.13.0-1.fc16.src.rpm): open (x86-14.phx2.fedoraproject.org) -> FAILED: BuildError: error building package (arch x86_64), mock exited with status 1; see build.log for more information
  0 free  0 open  0 done  2 failed

4008255 build (el5-candidate, rear-1.13.0-1.fc16.src.rpm) failed


Version-Release number of selected component (if applicable):
Only el5 seems to be a problem, el6, f16, f17 and f18 work fine

How reproducible:
koji build --arch=x86_64 --scratch el5-candidate RPM/SRPMS/rear-1.13.0-1.fc16.src.rpm

Steps to Reproduce:
1.
2.
3.
  
Actual results:
http://koji.fedoraproject.org/koji/getfile?taskID=4008256&name=root.log
shows error: unpacking of archive failed on file /builddir/build/SOURCES/rear-1.13.0.tar.gz;4f910907: cpio: MD5 sum mismatch

Expected results:
http://koji.fedoraproject.org/koji/getfile?taskID=4008254&name=root.log (of f18)

Additional info: with arch=i686 I have the same problem
[gdha@fedora ~]$ koji build --arch=i686 --scratch el5-candidate RPM/SRPMS/rear-1.13.0-1.fc16.src.rpm
Uploading srpm: RPM/SRPMS/rear-1.13.0-1.fc16.src.rpm
[====================================] 100% 00:00:03 321.37 KiB  99.50 KiB/sec
Created task: 4008963
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4008963
Watching tasks (this may be safely interrupted)...
4008963 build (el5-candidate, rear-1.13.0-1.fc16.src.rpm): free
4008963 build (el5-candidate, rear-1.13.0-1.fc16.src.rpm): free -> open (x86-03.phx2.fedoraproject.org)
  4008964 buildArch (rear-1.13.0-1.fc16.src.rpm, i686): open (x86-03.phx2.fedoraproject.org)
  4008964 buildArch (rear-1.13.0-1.fc16.src.rpm, i686): open (x86-03.phx2.fedoraproject.org) -> FAILED: BuildError: error building package (arch i686), mock exited with status 1; see build.log for more information
  0 free  1 open  0 done  1 failed
4008963 build (el5-candidate, rear-1.13.0-1.fc16.src.rpm): open (x86-03.phx2.fedoraproject.org) -> FAILED: BuildError: error building package (arch i686), mock exited with status 1; see build.log for more information
  0 free  0 open  0 done  2 failed

4008963 build (el5-candidate, rear-1.13.0-1.fc16.src.rpm) failed

[gdha@fedora ~]$ koji build --arch=i686 --scratch el6-candidate RPM/SRPMS/rear-1.13.0-1.fc16.src.rpm
Uploading srpm: RPM/SRPMS/rear-1.13.0-1.fc16.src.rpm
[====================================] 100% 00:00:02 321.37 KiB 109.41 KiB/sec
Created task: 4008974
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4008974
Watching tasks (this may be safely interrupted)...
4008974 build (el6-candidate, rear-1.13.0-1.fc16.src.rpm): free
4008974 build (el6-candidate, rear-1.13.0-1.fc16.src.rpm): free -> open (x86-12.phx2.fedoraproject.org)
  4008975 buildArch (rear-1.13.0-1.fc16.src.rpm, i686): open (x86-12.phx2.fedoraproject.org)
  4008975 buildArch (rear-1.13.0-1.fc16.src.rpm, i686): open (x86-12.phx2.fedoraproject.org) -> closed
  0 free  1 open  1 done  0 failed
4008974 build (el6-candidate, rear-1.13.0-1.fc16.src.rpm): open (x86-12.phx2.fedoraproject.org) -> closed
  0 free  0 open  2 done  0 failed

4008974 build (el6-candidate, rear-1.13.0-1.fc16.src.rpm) completed successfully
Comment 1 Dennis Gilmore 2012-04-20 13:19:07 EDT
fedora and rhel6 srpms are incompatible with rhel5 you need to use rpmbuild-md5 to make a rhel5 compatible srpm.

Note You need to log in before you can comment on or make changes to this bug.