Bug 814734 - qpidd qpid-txtest transaction integrity problems
Summary: qpidd qpid-txtest transaction integrity problems
Keywords:
Status: CLOSED DUPLICATE of bug 761023
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: Development
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: messaging-bugs
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-20 14:53 UTC by Frantisek Reznicek
Modified: 2015-11-16 01:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-07 14:37:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 761023 0 high CLOSED Message loss when broker is killed while txtest client is rotating messages in queues 2021-02-22 00:41:40 UTC

Internal Links: 761023

Description Frantisek Reznicek 2012-04-20 14:53:35 UTC
Description of problem:

Very rerely qpidd qpid-txtest transaction integrity problems were found on RHEL 6.2 i686 and RHEL 5.8 i386.

This bug might have link to bug 772166.

[09:57:49] ..ERROR:txtest logfile indicates failure that not all messages were rx'd (nr.lines:129 txtest.transcript.log):
  > [09:57:42] begin (run(B) 18/75 @step9]   )
  > [09:57:42] Command: /usr/bin/txtest  -p 5672 --messages-per-tx 114 --tx-count 143291 --total-messages 10763 --size 76 --queues 12 --check yes --init no --tra
nsfer no --dtx no --queue-base-name ZHm7JiX2Yag9yAwIfspXGxSOsyLdVmKTDuzHnKwvoBFBucq
  > Drained 9167 messages from ZHm7JiX2Yag9yAwIfspXGxSOsyLdVmKTDuzHnKwvoBFBucq-1
  > Drained 228 messages from ZHm7JiX2Yag9yAwIfspXGxSOsyLdVmKTDuzHnKwvoBFBucq-2
  > Drained 114 messages from ZHm7JiX2Yag9yAwIfspXGxSOsyLdVmKTDuzHnKwvoBFBucq-3
  > Drained 114 messages from ZHm7JiX2Yag9yAwIfspXGxSOsyLdVmKTDuzHnKwvoBFBucq-4
  > Drained 342 messages from ZHm7JiX2Yag9yAwIfspXGxSOsyLdVmKTDuzHnKwvoBFBucq-5
  > Drained 114 messages from ZHm7JiX2Yag9yAwIfspXGxSOsyLdVmKTDuzHnKwvoBFBucq-6
  > Drained 0 messages from ZHm7JiX2Yag9yAwIfspXGxSOsyLdVmKTDuzHnKwvoBFBucq-7
  > Drained 114 messages from ZHm7JiX2Yag9yAwIfspXGxSOsyLdVmKTDuzHnKwvoBFBucq-8



Version-Release number of selected component (if applicable):
> qpid-cpp-client-0.14-14.el5
> qpid-cpp-client-devel-0.14-14.el5
> qpid-cpp-client-devel-docs-0.14-14.el5
> qpid-cpp-client-rdma-0.14-14.el5
> qpid-cpp-client-ssl-0.14-14.el5
> qpid-cpp-mrg-debuginfo-0.14-14.el5
> qpid-cpp-server-0.14-14.el5
> qpid-cpp-server-cluster-0.14-14.el5
> qpid-cpp-server-devel-0.14-14.el5
> qpid-cpp-server-rdma-0.14-14.el5
> qpid-cpp-server-ssl-0.14-14.el5
> qpid-cpp-server-store-0.14-14.el5
> qpid-cpp-server-xml-0.14-14.el5
> qpid-java-client-0.14-3.el5
> qpid-java-common-0.14-3.el5
> qpid-java-example-0.14-3.el5
> qpid-jca-0.14-9.el5
> qpid-jca-xarecovery-0.14-9.el5
> qpid-jca-zip-0.14-9.el5
> qpid-qmf-0.14-9.el5
> qpid-qmf-debuginfo-0.14-9.el5
> qpid-qmf-devel-0.14-9.el5
> qpid-tests-0.14-1.el5
> qpid-tools-0.14-2.el5


How reproducible:
very rare, two attempts

Steps to Reproduce:
1. run qpid_test_transaction_integrity
  see details in linked Test case (TCMS)
  or below links

Actual results:
Transactional message loss.

Expected results:
No transactional message loss.

Comment 2 Frantisek Reznicek 2012-04-23 14:10:00 UTC
The buig is most probably duplicate or very close to bug 761023.

Comment 3 Frantisek Reznicek 2012-04-23 14:11:13 UTC
The bug is most probably duplicate or very close to bug 761023.

Comment 4 Leonid Zhaldybin 2012-09-14 12:27:46 UTC
The problem was also seen on RHEL6.3 x86_64, MRG/M 2.2 (qpid-cpp-0.14-22).

Comment 5 Justin Ross 2012-12-07 14:37:46 UTC

*** This bug has been marked as a duplicate of bug 761023 ***


Note You need to log in before you can comment on or make changes to this bug.