Bug 814778 - password change after setting password with adminpw is not persisted
password change after setting password with adminpw is not persisted
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 12:08 EDT by Mike Burns
Modified: 2016-04-26 11:20 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 10:12:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-04-20 12:08:00 EDT
Description of problem:
when installing rhevh using adminpw=<encrypted passwd>, you're prompted to reset the password on first login.  The new password should be persisted.  It's currently not persisted resulting in a need to change every reboot

Version-Release number of selected component (if applicable):
6.3-20120419.0

How reproducible:
Always

Steps to Reproduce:
1.install rhevh using autoinstall and adminpw=<hashed_password> (e.g. password1)
2.on next reboot, login as admin, reset password (e.g. password2)
3.reboot again
  
Actual results:
login with password2 fails
login with password1 succeeds but requires another password change

Expected results:
login with password2 is successful

Additional info:
Regression due to changes for adding libvirt-cim support
Comment 1 Mike Burns 2012-04-20 12:15:35 EDT
Workaround -- 

autoinstall using adminpw
login and change password
once on the TUI, change password again through the security tab.
Comment 2 Mike Burns 2012-04-20 12:21:51 EDT
http://gerrit.ovirt.org/3749

Testing:

install rhevh with adminpw=<hashed1>
after reboot, login as admin and change to password2 when forced to change
reboot
login as admin using password2
Comment 4 Guohua Ouyang 2012-04-28 01:18:17 EDT
verified with rhevh-6.3-20120426.2:
1. auto install with adminpw
2. login can change the password.
3. reboot 
4. login with the changed password successfully
Comment 5 Stephen Gordon 2012-06-13 15:44:25 EDT
Was this ever in a release version (read: is a technical note required)?
Comment 6 Mike Burns 2012-06-13 15:58:02 EDT
code existed in previous versions, but bug was never noticed previously.  It was a racy issue, so it might have existed, but never shown itself previously.
Comment 8 errata-xmlrpc 2012-07-19 10:12:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.