Bug 8148 - Various issues with initscripts (incl updated version)
Various issues with initscripts (incl updated version)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-03 12:54 EST by Henri J. Schlereth
Modified: 2014-03-16 22:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-13 10:46:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri J. Schlereth 2000-01-03 12:54:53 EST
intscripts turns off named as a default.
(verified with chkconfig on all machines)
initscripts adds usepeerdns to ifup-ppp. These two things generally
contrive to mess up internal DNS (non-Internet IP DNS).

I also have a question. I have 4 Linux boxs,aside from the the above
3 work just fine. On my firewall server I am forced to manually
insmod 8309,3c503,and the PPP modules or stuff wont work.

This is an upgrade from 6.0 -> 6.1
Comment 1 Bill Nottingham 2000-01-13 10:46:59 EST
Not starting bind was a change in policy (increased default security, among
other things).

Use 'chkconfig --level 35 named on' to turn it on, or use ntsysv.

To turn off peer dns on PPP, add 'PEERDNS=no' to
/etc/sysconfig/ifcfg-ppp<whatever>
Comment 2 Riley H Williams 2000-01-18 09:34:59 EST
Not sure about the rest of it, but to sort out the 8309 and 3c503 modules, you
need to put some entries in /etc/conf.modules to map them as required.

On my system, I have three network cards, and NE2000-ISA, and NE2000-PCI and a
DEC Tulip card, and I have the following entries to deal with them:

 Q> alias eth0 ne
 Q> options eth0 io=0x340 irq=9
 Q> alias eth1 ne2k-pci
 Q> alias eth2 tulip

The first two lines deal with the NE2000-ISA card, assigning it to eth0, the
third line assigns the NE2000-PCI card as eth1 and the last line assigns the DEC
Tulip card as eth2.

You will need to do something similar on your system.
Comment 3 Henri J. Schlereth 2000-01-18 10:10:59 EST
To: rhw@memalpha.cx
I know that you are sincere in your comments but all these things are already
set up in conf.modules after all this is my firewall server that connects to
the outside world and since I want to shorten the modeprobe for base addresses
I have had the following in conf.modules for years.
alias eth0 3c503
options 3c503 0x280

The 8390 device is taken care of under module-info under /boot.

To: notting@redhat.com

You outlined the fixes I already worked out. Dont you think this is a
problem for people with real DNS servers to find them suddenly turned off?
I run 8.2.2-P5 with good security scripts.

Or to add a feature under PPP that not everyone wants that again affects
DNS.

Also this ticket was closed, but what about the second half of my questions?
I have never gotten a adequate answer that explains to me why this one
machine locks up on the modprobe and I have to manually ismod the modules.
Comment 4 Riley H Williams 2000-01-18 10:16:59 EST
I would presume the `options` line actually reads...

    options 3c503 io=0x280

...but I will add that I have had problems in the past caused by the use of the
card type in the options line rather than the ethX port name. In theory it
should make no difference, but you may wish to check whether changing that to...

    options eth0 io=0x280

...makes any difference.
Comment 5 Henri J. Schlereth 2000-01-18 10:51:59 EST
Annoyingly that option change worked. But I remember that the original
setting I had came from the earlier documentation on the 3c503. I guess my
only question then remains why did it work with insmod and not in the
networking script? Ah well the mysteries of life and Linux.
Thanks a bunch, guess I aint too old to learn something new. Back to my
other problems.

Henri

Note You need to log in before you can comment on or make changes to this bug.