Bug 814814 - qemu has no 'qemu' binary
qemu has no 'qemu' binary
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qemu-launcher (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 14:45 EDT by cornel panceac
Modified: 2013-01-09 07:00 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 16:37:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2012-04-20 14:45:51 EDT
Description of problem:
$ which qemu
/usr/bin/which: no qemu in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/c0rnel/.local/bin:/home/c0rnel/bin)


Version-Release number of selected component (if applicable):

$ rpm -q qemu
qemu-1.0-11.fc17.i686

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
qemu binary should be present after installing qemu

Additional info:
i thought that maybe some things have changed and i don't know about it. so i installed the qemu launcher. it also complained that the 'qemu' binary is missing.
Comment 1 Paolo Bonzini 2012-04-23 04:00:56 EDT
QEMU binaries are called qemu-kvm, qemu-system-i386, qemu-system-x86_64.

Is qemu launcher installed from a Fedora package?
Comment 2 cornel panceac 2012-04-23 04:23:35 EDT
of course, the launcher was installed from official fedora repos. i've also checked if any other of the qemu\* packages should be installed, and i've not seen anyone. i'll check again anyway, asap, on a machine that is available right now.

otoh, if i'll create a symlink to qemu-i386, called qemu, will this "fix" the problem?
Comment 3 cornel panceac 2012-04-23 04:29:07 EDT
btw, i've forgot to mention: looking in the qemu.spec, i've noticed that the source is not from qemu, but from qemu-kvm.
Comment 4 Paolo Bonzini 2012-04-23 04:41:02 EDT
Creating a symlink to qemu-system-i386 or qemu-system-x86_64 will fix the problem.

Moving the bug to qemu-launcher.
Comment 5 cornel panceac 2012-04-23 05:30:15 EDT
from qemu.spec:

Source0: http://downloads.sourceforge.net/sourceforge/kvm/qemu-kvm-%{version}.tar.gz

Source1: qemu.binfmt
Comment 6 Daniel Berrange 2012-04-23 05:34:10 EDT
To quote the QEMU 1.0 release notes about why the 'qemu' binary went away:

  http://lists.nongnu.org/archive/html/qemu-devel/2011-12/msg00121.html


  "* i386-softmmu is no longer named ''qemu'' but instead referred to as 
     ''qemu-system-i386'' for better consistency with other targets. A
     new tool is likely to be introduced that uses the ''qemu'' name so
    distributions are advised to not undo this change."
Comment 7 Cole Robinson 2012-07-19 16:37:25 EDT
Since qemu-launcher is orphaned, I'm just closing this bug as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.