Bug 814819 - rtmon not installed by iproute package
rtmon not installed by iproute package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iproute (Show other bugs)
15
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 14:54 EDT by Devin Kelly
Modified: 2012-07-12 14:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: iproute-3.3.0-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 00:17:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devin Kelly 2012-04-20 14:54:32 EDT
Description of problem:  rtmon.c gets built but not installed.


Version-Release number of selected component (if applicable):
iproute-2.6.38.1.-2.fc15 and up

How reproducible:
always for iproute-2.6.38.1.-2.fc15 and up

Steps to Reproduce:
1. install iproute
2. try to use rtmon
  
Actual results:
can't find rtmon, because it wasn't installed (ie not in path)

Expected results:
Should be able to find rtmon in the users path.

Additional info:
to fix add 'ip/rtmon' to install targets in spec file and rebuild the rpm.  This worked for me.
Comment 1 Petr Šabata 2012-04-23 05:25:17 EDT
Indeed, it's missing.  rtmon was accidentally removed during the spec cleanup.
Comment 2 Fedora Update System 2012-04-30 10:43:56 EDT
iproute-3.3.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/iproute-3.3.0-2.fc17
Comment 3 Fedora Update System 2012-04-30 10:44:17 EDT
iproute-2.6.39-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/iproute-2.6.39-6.fc16
Comment 4 Fedora Update System 2012-04-30 14:47:05 EDT
Package iproute-3.3.0-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing iproute-3.3.0-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6928/iproute-3.3.0-2.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-05-07 00:17:52 EDT
iproute-3.3.0-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-05-22 06:47:06 EDT
iproute-2.6.38.1-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/iproute-2.6.38.1-7.fc15
Comment 7 Fedora Update System 2012-07-12 14:57:03 EDT
iproute-2.6.39-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.