Bug 814830 - ctrl-clicking on a function opens the new file in a plain text editor
ctrl-clicking on a function opens the new file in a plain text editor
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 15:17 EDT by Stephen Gallagher
Modified: 2013-01-16 08:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-16 08:35:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2012-04-20 15:17:23 EDT
Description of problem:
In previous versions of Eclipse, ctrl-click on a function would take you to the definition of that function in another file (usually a header file), which would be viewable in the C/C++ editor (with syntax highlighting, outline view, etc.). In Fedora 17, it opens the header file in a pure text editor without any of highlighting or other advanced features.

This is a serious regression in functionality.

Version-Release number of selected component (if applicable):
eclipse-cdt-8.1.0-0.4.junom6.fc17.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Open a C/C++ project
2. Open a C file in the C/C++ editor
3. ctrl-click on a function defined in a header file
  
Actual results:
The header file is opened as plain text

Expected results:
The header file should be opened in the C/C++ editor

Additional info:
Comment 1 Jeff Johnston 2012-04-20 19:13:17 EDT
I am using eclipse-4.2.0-0.15.I20120417100 in a VM that I installed the latest F17 beta and performed a package update.  I was unable to use the latest eclipse-4.2.0 (0.16) because it will not start up.

I installed the eclipse-cdt-8.1.0-0.4.junom6.fc17 as well.

I created a C project using the New->C Project wizard and chose Executable->Hello World ANSI C Project

The project built successfully and opened the main C file (hello.c).  I ctrl-clicked the puts function and it brought up the stdio.h header file in a new C editor.

Does this particular sequence work for you?

If yes, can you provide more info about your failing scenario so I may reproduce it?  

In either failing case, is there anything in the error log?  Help->About Eclipse->Installation Details->Configuration->View Error Log
Comment 2 Stephen Gallagher 2012-04-23 09:47:19 EDT
It's strange. It appears to only be happening for certain header files. I need to investigate further.
Comment 3 Jeff Johnston 2013-01-14 18:56:47 EST
Stephen, any more info on this?  Should I close this as works in current release?
Comment 4 Stephen Gallagher 2013-01-16 08:35:18 EST
I haven't seen this happening lately. I would assume that it's fixed. I'll reopen if I discover otherwise.

Note You need to log in before you can comment on or make changes to this bug.