Bug 814857 - Provide option to run polldaemon as a service
Provide option to run polldaemon as a service
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
Unspecified Linux
high Severity medium
: ---
: ---
Assigned To: Ondrej Kozina
Fedora Extras Quality Assurance
: FutureFeature
Depends On: 1222495
Blocks: 742564
  Show dependency treegraph
 
Reported: 2012-04-20 16:55 EDT by Alasdair Kergon
Modified: 2015-05-21 04:34 EDT (History)
11 users (show)

See Also:
Fixed In Version: lvm2-2.02.120-1.fc23
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-21 04:34:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alasdair Kergon 2012-04-20 16:55:34 EDT
polldaemon is currently forked off from the user's session.

If the user's session ends, it might get killed off before it has finished, effectively pausing whatever operation it was carrying out until a new daemon is forked off from some other process.

Find a sensible way to run this as a service.  (One option to consider is a merger with dmeventd.)
Comment 1 Peter Rajnoha 2013-05-28 04:17:29 EDT
There's already a common infrastructure that lvmetad uses currently for daemon code. We should reuse this (the "libdaemon" and around. Ondro - check the "libdaemon" subdir in lvm2 upstream and discuss with mornfall as he started with this common code).
Comment 2 Ondrej Kozina 2015-05-18 05:24:16 EDT
Fixed in upstream, release V2.02.120: https://git.fedorahosted.org/cgit/lvm2.git/commit/?id=0300730cc9ba058df830d9cb0981183b90ad17db
Comment 3 Peter Rajnoha 2015-05-18 10:07:04 EDT
Prepared for rawhide build and enabling the lvmpolld there, I'll just wait for bug #1222495 - systemd to have a system preset that makes the service enabled by default which is the proper way to have the service enabled by default.

(I asked Lukas Nykryn from systemd team directly about this - he noted that currently the preset file is being moved from systemd to fedora-release package and we noticed that currently the /usr/lib/systemd/system-preset/90-default.preset incorrectly belongs to both packages at the moment somehow, so he's going to resolve this and he'll make a build soon, also including our patch to have lvmpolld enabled by default.)
Comment 4 Peter Rajnoha 2015-05-21 04:34:20 EDT
lvmpolld daemon enabled and used by default in rawhide since lvm2-2.02.120-1.fc23.

Note You need to log in before you can comment on or make changes to this bug.