Bug 814868 - RFE: Expose the 4ti2 library
RFE: Expose the 4ti2 library
Status: CLOSED DUPLICATE of bug 869088
Product: Fedora
Classification: Fedora
Component: 4ti2 (Show other bugs)
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Mark Chappell
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-04-20 17:34 EDT by Jerry James
Modified: 2012-10-22 22:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-10-22 22:27:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Proposed 4ti2.spec that builds and install the library (4.36 KB, text/x-rpm-spec)
2012-04-20 17:34 EDT, Jerry James
no flags Details

  None (edit)
Description Jerry James 2012-04-20 17:34:40 EDT
Created attachment 579110 [details]
Proposed 4ti2.spec that builds and install the library

Description of problem:
I'm trying to package LattE integrale, which can be used by polymake for certain operations.  The LattE configure script tries to find the 4ti2 library and header files, but we don't ship them, instead building the library into every binary.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
I'm attaching a proposed new spec file which produces the library.
Comment 1 Mark Chappell 2012-04-26 14:08:52 EDT

IIRC, last time I looked at the libraries I think they didn't look like proper shared libraries (I may be wrong there were several libraries I was packaging at the same time).

If you have a need for them then I'm more than happy for them to get added to the bundle.

Are you already an approved packager?  If so then I'm happy to grant you commit access on the package.  My new day job keeps me much busier, and on different projects than my previous job, so I do apologise if I'm a little unresponsive.

Comment 2 Jerry James 2012-10-12 17:56:11 EDT
(Six months later...)

Sorry for the delay.  I've been trying to reach one of the 4ti2 developers to clear up some issues.  I finally found an email address that got a response, months later.  Here's the story.  Development of 4ti2 has moved to the LattE project (http://www.math.ucdavis.edu/~latte/), along with Matthias Köppe, one of the original 4ti2 developers, who is now part of the LattE team.  Matthias tells me that he will soon post notices on both www.4ti2.de and the LattE web site noting this change of upstream.  LattE integrale 1.5.3 contains 4ti2 version 1.5, which is structured to be a shared library for use by LattE.

I have posted a preliminary combined 4ti2 / LattE package here:  http://jjames.fedorapeople.org/latte-integrale/.  I think we need to deprecate the existing 4ti2 package, and review the one I posted.  If you have any thoughts on the matter, I would like to hear them.  Thanks.
Comment 3 Jerry James 2012-10-22 22:27:07 EDT
With Mark and Rex's approval, I have opened a review bug for latte-integrale, which includes the latest version of 4ti2: bug 869088.  I'll close this bug as a duplicate of the other.

*** This bug has been marked as a duplicate of bug 869088 ***

Note You need to log in before you can comment on or make changes to this bug.