Bug 814874 - Please include /etc/e2fsck.conf in initramfs
Please include /etc/e2fsck.conf in initramfs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 18:30 EDT by Eric Sandeen
Modified: 2012-04-25 01:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: dracut-018-23.git20120419.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 01:04:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2012-04-20 18:30:45 EDT
See also [Bug 748920] Setting back time breaks boot

I've added /etc/e2fsck.conf to the e2fsprogs package, but to make the change effective for the root fs at boot time, /etc/e2fsck.conf will need to be present in the initramfs.

This was bandied about a as a blocker for F17, so I guess it's high-ish priority?

Since /etc/e2fsck.conf didn't exist before, you might need to make it non-fatal if it's not there, if possible.

Thanks,
-Eric
Comment 1 Harald Hoyer 2012-04-23 05:00:30 EDT
already in dracut-018-1.fc17.noarch
Comment 2 Fedora Update System 2012-04-23 05:04:20 EDT
dracut-018-23.git20120419.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-6258/dracut-018-23.git20120419.fc17
Comment 3 Eric Sandeen 2012-04-23 10:49:20 EDT
Thanks Harald !

So with this update and e2fsprogs-1.42-4.fc17 in place, re-running dracut (or installing a new kernel) will create a new initramfs with an e2fsck which should not stop on the clock problem.

-Eric
Comment 4 Fedora Update System 2012-04-25 01:04:19 EDT
dracut-018-23.git20120419.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.