Bug 814879 - FTBFS: Buld failure on PPC64: ./yarr/pcre/pcre.h:49:18: fatal error: jstl.h: No such file or directory
FTBFS: Buld failure on PPC64: ./yarr/pcre/pcre.h:49:18: fatal error: jstl.h: ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
17
powerpc Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 840588
  Show dependency treegraph
 
Reported: 2012-04-20 19:17 EDT by Gustavo Luiz Duarte
Modified: 2012-07-16 11:55 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 840588 (view as bug list)
Environment:
Last Closed: 2012-06-20 09:51:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use YARR interpreter instead of PCRE on platforms where YARR JIT is not supported (12.20 KB, patch)
2012-04-25 14:11 EDT, Gustavo Luiz Duarte
no flags Details | Diff
Only build SPS on supported platforms (4.54 KB, patch)
2012-04-25 14:14 EDT, Gustavo Luiz Duarte
no flags Details | Diff
Disable JEMALLOC_STATIC_SIZES on powerpc (546 bytes, patch)
2012-04-25 14:20 EDT, Gustavo Luiz Duarte
no flags Details | Diff

  None (edit)
Description Gustavo Luiz Duarte 2012-04-20 19:17:10 EDT
Description of problem:
xulrunner-11.0-3.fc17 fails to build on PPC64 with the following error:

c++ -o jsanalyze.o -c  -fvisibility=hidden -DOSTYPE=\"Linux2.6.32-220.4.2.el6\" -DOSARCH=Linux -DEXPORT_JS_API -DIMPL_MFBT -DJS_HAS_CTYPES -DDLL_PREFIX=\"lib\" -DDLL_SUFFIX=\".so\" -DNO_NSPR_10_SUPPORT -Ictypes/libffi/include -I.  -I. -I. -I./../../dist/include -I./../../dist/include/nsprpub  -I/usr/include/nspr4  -I. -I./assembler -I./yarr  -fPIC  -fno-rtti -pedantic -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -Wno-long-long -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fno-exceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -fpermissive -pthread -pipe  -DNDEBUG -DTRIMMED -g -O3 -freorder-blocks  -fomit-frame-pointer -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1   -DMOZILLA_CLIENT -include ./js-confdefs.h -MD -MF .deps/jsanalyze.pp /builddir/build/BUILD/xulrunner-11.0/mozilla-release/js/src/jsanalyze.cpp
In file included from ./vm/RegExpObject.h:54:0,
                 from ./jsscriptinlines.h:53,
                 from /builddir/build/BUILD/xulrunner-11.0/mozilla-release/js/src/vm/Stack-inl.h:49,
                 from /builddir/build/BUILD/xulrunner-11.0/mozilla-release/js/src/jsinferinlines.h:50,
                 from /builddir/build/BUILD/xulrunner-11.0/mozilla-release/js/src/jsanalyze.cpp:45:
./yarr/pcre/pcre.h:49:18: fatal error: jstl.h: No such file or directory


Version-Release number of selected component (if applicable):
xulrunner-11.0-3.fc17

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f17 xulrunner-11.0-3.fc17.src.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=483598

Expected results:


Additional info:
Comment 1 Gustavo Luiz Duarte 2012-04-25 14:11:10 EDT
Created attachment 580226 [details]
Use YARR interpreter instead of PCRE on platforms where YARR JIT is not supported

Based on Landry Breuil's patch posted on the upstream bug: https://bugzilla.mozilla.org/show_bug.cgi?id=691898
Comment 2 Gustavo Luiz Duarte 2012-04-25 14:14:08 EDT
Created attachment 580229 [details]
Only build SPS on supported platforms

Based on Mike Hommey's patch posted on the upstream bug: https://bugzilla.mozilla.org/show_bug.cgi?id=734335
Comment 3 Gustavo Luiz Duarte 2012-04-25 14:20:27 EDT
Created attachment 580231 [details]
Disable JEMALLOC_STATIC_SIZES on powerpc

Disables the use of JEMALLOC_STATIC_SIZES on powerpc since it assumes 4k page size. JEMALLOC_STATIC_SIZES was introduced after landing of: https://bugzilla.mozilla.org/show_bug.cgi?id=571209
Comment 4 Gustavo Luiz Duarte 2012-04-25 14:35:07 EDT
I was able to build xulrunner-12.0-1.fc17 on powerpc:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=512647

I used the patches #580226, #580229 and #580231 to build xulrunner on powerpc. It was not needed to build successfully, but I also used in my scratch build Martin's patch posted here: https://bugzilla.mozilla.org/show_bug.cgi?id=746112

firefox-12.0-1.fc17 built with no issues.

I tested the built packages on ppc64 and it works as good as [xulrunner|firefox]-10.0-1.fc17.

If you are interested, I have also xulrunner-11.0-3.fc17 version of these patches.
Comment 5 Martin Stransky 2012-04-26 03:18:10 EDT
"it works as good as [xulrunner|firefox]-10.0-1.fc17" - so does it freeze or not? (Bug 813095).
Comment 6 Gustavo Luiz Duarte 2012-04-26 03:26:23 EDT
Yes, it does :(
Comment 7 Martin Stransky 2012-05-03 05:42:17 EDT
The patch should be included in Firefox 15.
Comment 8 Dan Horák 2012-05-07 10:32:46 EDT
The changes are committed to master branch in Fedora and a scratch build is at http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=535816
Marting will update F<=17 branches later.
Comment 9 Peter Lemenkov 2012-05-07 10:55:52 EDT
(In reply to comment #8)
> The changes are committed to master branch in Fedora and a scratch build is at
> http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=535816
> Marting will update F<=17 branches later.

Still consumes 100% CPU while executing jscripts. If I switch to safe mode it starts at least.

I wonder can we borrow some PPC-related patches from TenFourFox project. I'm using it on a daily basis and it works good.

http://code.google.com/p/tenfourfox/
Comment 10 Martin Stransky 2012-05-14 04:31:33 EDT
The bug on PPC/Fedora17 is cuased by broken gcc47 on ppc. The firefox version is not related here.
Comment 11 Martin Stransky 2012-06-20 09:51:28 EDT
It should be already fixed on F17.

Note You need to log in before you can comment on or make changes to this bug.