Bug 814893 - Mouse lag when using F16 kernels 3.3.2-1 or 3.3.1-5
Mouse lag when using F16 kernels 3.3.2-1 or 3.3.1-5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 23:16 EDT by Keegan Callin
Modified: 2012-11-05 08:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-05 08:37:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg for a working version of kernel 3.1.0-7 (84.50 KB, text/plain)
2012-04-20 23:17 EDT, Keegan Callin
no flags Details
dmesg for a bugged version of the kernel, 3.3.2-1 (71.95 KB, text/plain)
2012-04-20 23:18 EDT, Keegan Callin
no flags Details

  None (edit)
Description Keegan Callin 2012-04-20 23:16:37 EDT
Description of problem:

When moving the mouse it momentarily freezes and races like it is playing a children's game of "red-light, green-light".  Trying to trace a circle in, say, kolourpaint is an exercise in aggravation.


Version-Release number of selected component (if applicable):

vmlinuz-3.3.1-5.fc16.x86_64 [Problem]
vmlinuz-3.3.2-1.fc16.x86_64 [Problem]

How reproducible:
Always


Steps to Reproduce:
1. Boot to vmlinuz-3.3.2-1.fc16.x86_64 or vmlinuz-3.3.1-5.fc16.x86_64
2. Wait for login
3. Move mouse in circle and observe the lag.
  
Actual results:
Aggravation.  Difficult to click buttons when mouse freezes and then overshoots buttons.

Expected results:
Joy, peace, precision mousing.

Additional info:

Mouse is a Logitech USB wireless keyboard & optical mouse setup.  I have the part numbers if you want.

Mouse works fine whenever booted to vmlinuz-3.1.0-7.fc16.x86_64 kernel.  Booting into the newer kernels, vmlinuz-3.3.1-5.fc16.x86_64 or vmlinuz-3.3.2-1.fc16.x86_64 manifests the problem.
Comment 1 Keegan Callin 2012-04-20 23:17:50 EDT
Created attachment 579143 [details]
dmesg for a working version of kernel 3.1.0-7
Comment 2 Keegan Callin 2012-04-20 23:18:34 EDT
Created attachment 579144 [details]
dmesg for a bugged version of the kernel, 3.3.2-1
Comment 3 Josh Boyer 2012-04-21 12:02:38 EDT
You have a buggy PCI bridge.  See bug 755956

[    0.352798] pci 0000:07:00.0: Buggy bridge found [1b21:1080]
[    0.352799] pci 0000:07:00.0: Stuck interrupts will be polled and retried

Fedora has a patch that tries to work around the broken hardware by switching to polling mode for interrupts.  This works decently enough to keep the hardware from just being disabled, but it means you can get some laggy behaviour.

Your particular machine doesn't seem to have anything behind that bridge though, which means the workaround is fairly pointless.  We haven't found a great way to stop doing the quirk in this specific case yet.
Comment 4 Dave Jones 2012-10-23 11:29:14 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 5 Keegan Callin 2012-11-03 22:22:07 EDT
[root@XXXXXXXXXX ~]# uname -a
Linux grizzly 3.6.2-1.fc16.x86_64 #1 SMP Wed Oct 17 05:30:01 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

My system configuration has not changed since creating this ticket.  After the new kernel the mouse lag has either disappeared or is so low that I do not notice it.
Comment 6 Josh Boyer 2012-11-05 08:37:32 EST
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.