Bug 814955 - Anaconda aborts with message about not continuing, -- Reboot
Anaconda aborts with message about not continuing, -- Reboot
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-21 11:06 EDT by Leslie Satenstein
Modified: 2012-12-29 12:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-29 12:06:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leslie Satenstein 2012-04-21 11:06:25 EDT
Description of problem:

Fedora 17 Beta was being installed, on a disk partitioned as follows:
disk size   250gig sata
Format of disk  mdos
partition layout 4 logical partitions of 60 gigs ext4 for partitions 2,3,4
partition one was set to deleted.
A Linux with grub2 (mint) was removed to allow Fedora installation. 
Wired Internet -- not wireless.
System has 3 physical drives.

Version-Release number of selected component (if applicable):

Fedora 17 beta. Full Install DVD -- not the CD version

How reproducible:

Boot DVD and run and select to install on the deleted partition (see above), with boot drive selected to be on the same physical disk. 

Steps to Reproduce:
1. Format disk without it having physical partitions (4 logical partitions).
2. Create all partitions as ext4, then delete partition 1 to force anaconda to install therein. 
3. Boot Fedora 17 DVD
4. Select to install on deleted partition on this 3rd drive
5. Anaconda executes past the selection of where to install grub
6  Anaconda stops execution with attempt to send error message to bugzilla.
7  Beta Fedora should have a specific bugzilla user setup so bug could be recorded. Bugzilla did not work.

  
Actual results:

Had to use full disk

Expected results:

Wanted F17 to install only on that partition, allowing F17 to use lvm and default configuration

Additional info:
Comment 1 Leslie Satenstein 2012-04-21 11:11:03 EDT
Anaconda futures
Can there be a graphical anaconda that will show a disks existing layout, and via graphical actions, select the disk, and partition, and location for mbr update as well as swap location.
I know that newer machines will have a different bios, with rule changing for disk architecture, but perhaps it is time to make anaconda more user friendly for the debutant or first time user. Please note, even we who have been with Fedora 6 years, only do installs one time with each new release about two times per year.
Comment 2 Chris Lumens 2012-04-23 10:16:16 EDT
Please attach the complete traceback message to this bug report.  You can also save this data via a USB drive during installation.  Without the traceback, we won't be able to do anything about this problem.
Comment 3 Leslie Satenstein 2012-04-23 11:18:10 EDT
Chris, Sorry to say, I did not find a way to capture the traceback after the reboot. Now I know to write to a flash drive.  I very much tried to post to bugzilla, and that failed.

May I make a suggestion for the future.

Anaconda should have it's own bugzilla capability. When I tried to send it, even though the (network connection was OK), it met with failure.

Again,  The sata drive was purposely formatted without a primary partition, only with 4 logical ones.

Your clue,  no primary partition. Created 4 logical partitions. 
Format all logicals to ext2,
Delete logical partition#1
exit gparted and F16
reboot with DVD and F17 beta.
System is dual core (intel) 64bit version

Redoing the disk (mdos device mbr), followed by creating 4 primary partitions worked just fine.

My practice from Fedora 6 and beyond was to always delete the partition# onto which I wanted to install Fedora. That is the way I found to always succeed with an installation. So yes, the logical partition 1 was deleted, with the other logical partitions formatted ext2. Perhaps this method does not work with logical partitions on a freshly prepared drive.

If in the next few days I decide to redo from the beginning a Fedora 17 install to see if the error can be recreated, I will do the zero real, 4 logical.

The off topic (anaconda futures) about making better use of the gui, is not part of this bug.
Comment 4 Jesse Keating 2012-07-18 14:32:19 EDT
You need to provide more information for us to reproduce this issue.  Like actual partition listings from parted before the install attempt, what exact options you picked for the F17 partitioning screen(s), parted partition listings after that stage.  I'm unable to reproduce with just the information given here.
Comment 5 Leslie Satenstein 2012-12-29 12:06:16 EST
Since Anaconda is a rewrite, and Fedora 18 is the new release, and since noone else has reported this problem, I leave it to you to close. 

In short order, F17 anaconda development will be frozen, if it has not already.

Note You need to log in before you can comment on or make changes to this bug.