Bug 814959 - Unable to access eclipse-cdt functionality
Unable to access eclipse-cdt functionality
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-21 12:01 EDT by David Betz
Modified: 2016-07-14 14:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 03:55:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Betz 2012-04-21 12:01:14 EDT
Description of problem:
Fresh install of Fedora 17 beta. Install of eclipse-cdt. Start eclipse. Select File->New Project. C++ project types are not available.

Version-Release number of selected component (if applicable):
Fedora 17 beta.

eclipse-platform-4.2.0-0.15.I201204171000.fc17.x86_64
eclipse-cdt-8.1.0-0.3.junom6.fc17.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Fresh install of Fedora 17 beta
2. Add Software of eclipse-cdt
3. Attempt to create a new c++ project.
  
Actual results:
The only project types listed in eclipse are:
General
CVS

Expected results:
The ability to create a new c++ project

Additional info:

When starting eclipse from the command line, this line appears in the output:

org.eclipse.equinox.p2.core.ProvisionException: Error: file:/usr/lib64/eclipse/dropins/cdt/ is not a valid extension location because it already contains a standard p2 repository file.

I have tried, in various permutations to start eclipse -initialize from root, rm .eclipse and workspace, and ultimately delete certain files in the /usr/lib64/eclipse hierarchy, without success.
Comment 1 Andrew Overholt 2012-04-23 09:19:45 EDT
This seems like a dropins problem, right, Chris?
Comment 2 Alexander Kurtakov 2012-04-23 09:33:16 EDT
This bug is caused by cdt shipping p2 metadata in a dropins location in older release. As p2 is clearly saying that in the log it looks like something that has been done on purpose.
Comment 3 Andrew Overholt 2012-04-23 09:50:37 EDT
David, could you try the packages here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=314463

and let us know if they fix this for you?  Thanks.
Comment 4 David Betz 2012-04-23 20:08:07 EDT
I installed the packages you suggested, did a "rm -rf workspace .eclipse" and ran "eclipse -clean -initialize", and now I can see C++ project options.

Thanks for your effort.
Comment 5 Alexander Kurtakov 2012-04-24 03:55:32 EDT
Closing as it worked for the reporter.
Comment 6 evaristojosec 2016-07-14 12:56:59 EDT
I have seen that all eclipse plugins in FC24 are installed in /usr/share/eclipse/droplets but eclipse-finbugs is installed under /usr/share/eclipse/dropins and I guess that could the root of the problem
Comment 7 Alexander Kurtakov 2016-07-14 13:30:42 EDT
F24 is the first release where droplets is used. Most plugins are converted and rest are work in progerss. Why do you comment on this bug btw? Would you please open a new one for your issue against F24, the problem you are facing is definetely different than what this bug was for.
Comment 8 evaristojosec 2016-07-14 14:16:11 EDT
My intention was to comment on https://bugzilla.redhat.com/show_bug.cgi?id=1356462 that reports the bug in F24, but by mistake I reported here (I had 2 different browser windows with both issues).

Sorry for the mistake

Note You need to log in before you can comment on or make changes to this bug.