Bug 81497 - don't restart daemons
Summary: don't restart daemons
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logrotate
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-09 22:29 UTC by Neil Prockter
Modified: 2015-01-08 00:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-13 19:24:12 UTC


Attachments (Terms of Use)

Description Neil Prockter 2003-01-09 22:29:29 UTC
Description of problem: logrotate restarts systems daemons, whilst this maybe
fine for desktops for servers this can be disasterous


Version-Release number of selected component (if applicable):


How reproducible:
for worst result, change apache config, get it wrong, wait for logrotate to try
to restart apache and apply changes then fail at 4am. no service for 5 hours!
(hasn't happened to me yet thank goodness)

Steps to Reproduce:
1.
2.
3.
    
Actual results:
restarts systems daemons

Preferred results:
leave daemons alone

Additional info:

Comment 1 Elliot Lee 2003-01-13 19:24:12 UTC
Daemons have to be restarted in order for logging to continue to work - if apache does not 
get restarted, then there is no logging at all, because the information is being written to old, 
now-deleted logfiles.

To prevent the situation you describe, don't leave the system with an invalid or untested 
configuration.


Note You need to log in before you can comment on or make changes to this bug.