Bug 814989 - FTBFS, license outdated
FTBFS, license outdated
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Module-Starter-Plugin-CGIApp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-21 17:58 EDT by Paul Howarth
Modified: 2012-05-26 02:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-20 19:56:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2012-04-21 17:58:18 EDT
Build in Rawhide currently failing:

Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.kJYBme
+ umask 022
+ cd /builddir/build/BUILD
+ cd Module-Starter-Plugin-CGIApp-0.30
+ unset DISPLAY
+ ./Build test
t/00-signature.t ........ skipped: Set the environment variable TEST_SIGNATURE to enable this test.
# Testing Module::Starter::Plugin::CGIApp 0.30, Perl 5.014002, /usr/bin/perl
t/01-load.t ............. ok
t/distmanifest.t ........ skipped: Author tests not required for installation
Can't locate object method "lib/Foo/Bar.pm" via package "Module::Starter" at /usr/share/perl5/vendor_perl/Module/Starter/Simple.pm line 1035.
t/extutils-makemaker.t ..
Dubious, test returned 25 (wstat 6400, 0x1900)
No subtests run
t/hasversion.t .......... skipped: Author tests not required for installation
t/kwalitee.t ............ skipped: Author tests not required for installation
t/meta.t ................ skipped: Author tests not required for installation
t/minimumversion.t ...... skipped: Author tests not required for installation
Can't locate object method "lib/Foo/Bar.pm" via package "Module::Starter" at /usr/share/perl5/vendor_perl/Module/Starter/Simple.pm line 1035.
t/module-build.t ........
Dubious, test returned 25 (wstat 6400, 0x1900)
No subtests run
Can't locate object method "lib/Foo/Bar.pm" via package "Module::Starter" at /usr/share/perl5/vendor_perl/Module/Starter/Simple.pm line 1035.
t/module-install.t ......
Dubious, test returned 25 (wstat 6400, 0x1900)
No subtests run
t/perl-critic.t ......... skipped: Author tests not required for installation
t/pod-coverage.t ........ skipped: Author tests not required for installation
t/pod.t ................. skipped: Author tests not required for installation
Test Summary Report
-------------------
t/extutils-makemaker.t (Wstat: 6400 Tests: 0 Failed: 0)
  Non-zero exit status: 25
  Parse errors: No plan found in TAP output
t/module-build.t      (Wstat: 6400 Tests: 0 Failed: 0)
  Non-zero exit status: 25
  Parse errors: No plan found in TAP output
t/module-install.t    (Wstat: 6400 Tests: 0 Failed: 0)
  Non-zero exit status: 25
  Parse errors: No plan found in TAP output
Files=13, Tests=1,  1 wallclock secs ( 0.04 usr  0.01 sys +  0.57 cusr  0.10 csys =  0.72 CPU)
Result: FAIL
Failed 3/13 test programs. 0/1 subtests failed.
error: Bad exit status from /var/tmp/rpm-tmp.kJYBme (%check)

Had a quick look at it but couldn't see anything obvious wrong.

Also I think the license should be "GPLv2+ or Artistic 2.0".
Comment 1 Emmanuel Seyman 2012-04-22 03:55:43 EDT
(In reply to comment #0)
> 
> Had a quick look at it but couldn't see anything obvious wrong.

perl-Module-Starter-1.54 broke this module.

I've tried taking a look at the problem without success. Upstream never responded to my email. I'll try again.

> Also I think the license should be "GPLv2+ or Artistic 2.0".

Humm... The Meta.yml file and the main module say different things. I'll ping upstream on this.
Comment 2 Fedora Update System 2012-05-11 18:42:29 EDT
perl-Module-Starter-Plugin-CGIApp-0.41-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/perl-Module-Starter-Plugin-CGIApp-0.41-1.fc16
Comment 3 Fedora Update System 2012-05-11 18:42:59 EDT
perl-Module-Starter-Plugin-CGIApp-0.41-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/perl-Module-Starter-Plugin-CGIApp-0.41-1.fc17
Comment 4 Fedora Update System 2012-05-12 15:45:07 EDT
Package perl-Module-Starter-Plugin-CGIApp-0.41-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Module-Starter-Plugin-CGIApp-0.41-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7747/perl-Module-Starter-Plugin-CGIApp-0.41-1.fc17
then log in and leave karma (feedback).
Comment 5 Emmanuel Seyman 2012-05-20 09:36:12 EDT
(In reply to comment #0)
> 
> Also I think the license should be "GPLv2+ or Artistic 2.0".

Having talked it over with the author, he's amended his license to 'same as Perl' everywhere in the module. Module-Starter-Plugin-CGIApp 0.41 is in rawhide (but nowhere else).
Comment 6 Fedora Update System 2012-05-20 19:56:36 EDT
perl-Module-Starter-Plugin-CGIApp-0.41-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-05-26 02:53:13 EDT
perl-Module-Starter-Plugin-CGIApp-0.41-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.