Bug 815025 - pathinfo extended attribute shows latests set block size for all the files
pathinfo extended attribute shows latests set block size for all the files
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: shishir gowda
: Reopened
Depends On: 766530
Blocks: 811632
  Show dependency treegraph
 
Reported: 2012-04-22 03:15 EDT by Scott Haines
Modified: 2015-01-22 10:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 766530
Environment:
Last Closed: 2012-05-01 07:17:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0538 normal SHIPPED_LIVE Red Hat Storage Software Appliance 3.2 bug fix update. 2012-05-01 11:15:12 EDT

  None (edit)
Description Scott Haines 2012-04-22 03:15:39 EDT
+++ This bug was initially created as a clone of Bug #766530 +++

Description of problem:
Pathinfo extended attribute shows latest set block size for the files created with different block size

Version-Release number of selected component (if applicable):
3.3.0qa15

How reproducible:
Always

Steps to Reproduce:
1.Create a stripe volume and mount it 

2.Create some file on mount points , now these files have block size 128KB

3.Change the block size for the volume through volume set, say 1MB

4. Now create some files on the mount point, these files should have block size as 1MB

5. Now execute the command " getfattr -m . -n trusted.glusterfs.pathinfo * "

Actual results:
For all the files block size shown as 1MB

Expected results:
Block size should be same as the size with which the file was created

Additional info:

--- Additional comment from shmohan@redhat.com on 2011-12-12 04:58:20 EST ---

Actually it's showing 64MB no matter whatever the blocksize is

--- Additional comment from aavati@redhat.com on 2012-01-03 12:15:37 EST ---

CHANGE: http://review.gluster.com/2545 (cluster/stripe: Fix block size reported in pathinfo xattr) merged in master by Vijay Bellur (vijay@gluster.com)

--- Additional comment from aavati@redhat.com on 2012-01-04 02:10:59 EST ---

CHANGE: http://review.gluster.com/2549 (cluster/stripe: Fix block size reported in pathinfo xattr) merged in release-3.2 by Vijay Bellur (vijay@gluster.com)

--- Additional comment from shmohan@redhat.com on 2012-01-16 07:48:28 EST ---

Now another issue is while verifying this bug

1. Created a stripe volume , touched some files , block size was default
2. changed the block size using volume set to 2MB, whatever the files created after this and previously created files has proper block sizes.
3. Now i changed the stripe size to 8MB, files created after this still shows 2MB as block size

so reopening the bug

--- Additional comment from vshankar@redhat.com on 2012-01-16 10:54:16 EST ---

(In reply to comment #4)
> Now another issue is while verifying this bug
> 
> 1. Created a stripe volume , touched some files , block size was default
> 2. changed the block size using volume set to 2MB, whatever the files created
> after this and previously created files has proper block sizes.
> 3. Now i changed the stripe size to 8MB, files created after this still shows
> 2MB as block size

If this is on 3.2, this is known problem as the update is not handled in the reconfigure part. I'll get look that up. It should be fine in master, can you please check that.

Also, for now you remount the volume and then check the block sizes for freshly created files.

> 
> so reopening the bug

--- Additional comment from vshankar@redhat.com on 2012-01-17 00:37:54 EST ---

Sorry, my bad. The fix in the reconfigure part is still not in master yet.

--- Additional comment from shmohan@redhat.com on 2012-04-20 05:59:42 EDT ---

Verified on 3.3 master working fine.
Comment 3 errata-xmlrpc 2012-05-01 07:17:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0538.html

Note You need to log in before you can comment on or make changes to this bug.