Bug 81503 - konqueror crashes on a double click
konqueror crashes on a double click
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-09 18:04 EST by Michal Jaegermann
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-10 14:11:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2003-01-09 18:04:45 EST
Description of problem:

Clicking on a text file icon in a directory window brought only a crash
dialog with the following backtrace:

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
0x40ef1bc2 in waitpid () from /lib/i686/libpthread.so.0
#0  0x40ef1bc2 in waitpid () from /lib/i686/libpthread.so.0
#1  0x40639a7d in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#2  <signal handler called>
#3  0x40276a48 in KApplicationTree::addDesktopGroup(QString, KAppTreeListItem*)
    () from /usr/lib/libkio.so.4
#4  0x40276962 in KApplicationTree::KApplicationTree(QWidget*) ()
   from /usr/lib/libkio.so.4
#5  0x40278d91 in KOpenWithDlg::init(QString const&, QString const&) ()
   from /usr/lib/libkio.so.4
#6  0x40277d9e in KOpenWithDlg::KOpenWithDlg(KURL::List const&, QString const&,
QString const&, QWidget*) () from /usr/lib/libkio.so.4
#7  0x401f2f7d in KRun::displayOpenWithDialog(KURL::List const&) ()
   from /usr/lib/libkio.so.4
#8  0x401f2b82 in KRun::runURL(KURL const&, QString const&) ()
   from /usr/lib/libkio.so.4
#9  0x401f96c4 in KRun::foundMimeType(QString const&) ()
   from /usr/lib/libkio.so.4
#10 0x401f7c6c in KRun::init() () from /usr/lib/libkio.so.4
#11 0x401f8b1f in KRun::slotTimeout() () from /usr/lib/libkio.so.4
#12 0x401fa3ef in KRun::qt_invoke(int, QUObject*) () from /usr/lib/libkio.so.4
#13 0x409a7049 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#14 0x409a6eed in QObject::activate_signal(int) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#15 0x40c8860b in QTimer::timeout() () from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#16 0x409c7e92 in QTimer::event(QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#17 0x40948ed4 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#18 0x40948ac9 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#19 0x405ce3f9 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#20 0x40923d75 in QEventLoop::activateTimers() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#21 0x409018c8 in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#22 0x4095cca6 in QEventLoop::enterLoop() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#23 0x4095cb48 in QEventLoop::exec() () from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#24 0x40949101 in QApplication::exec() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#25 0x412906b7 in main () from /usr/lib/konqueror.so
#26 0x0804ca41 in strcpy ()
#27 0x0804d6fb in strcpy ()
#28 0x0804dbac in strcpy ()
#29 0x0804e8a9 in strcpy ()
#30 0x42015970 in __libc_start_main () from /lib/i686/libc.so.6
Comment 1 Warren Togami 2003-01-12 05:35:43 EST
I can't reproduce this.  How big is that text file that caused the crash?  Does
it occur with any text file?  Any other type of file?

If it occurs only with one text file, please send that to me directly via e-mail
so I can test it too.
Comment 2 Michal Jaegermann 2003-01-12 15:54:51 EST
All right!  When /usr/bin/desktop-create-kmenu runs into troubles
(one possible reason is shown in bug #81512 but there are likely multiple
other failure modes) then /var/lib/menu/kde is absent.  Then clicking
in a konqueror window on an icon for a file which has a name with a suffix
(say 'my.log') without a predefined action is causing an immediate SIGSEGV
with a backtrace as described.  A file content is totally immaterial.
As an aside, I always thought that 'file' utility determines file types
on Linux/Unix because "extensions" are really worthless for anything serious.

For an extra fun even if /var/lib/menu/kde is already there but
/usr/bin/desktop-create-kmenu failed then, before bailing out, it will
clobber an old /var/lib/menu/kde anyway; but this kind of fragility in KDE
is hardly of any surprise.
Comment 3 Ngo Than 2003-02-10 14:11:03 EST
it's fixed in 3.1-5 or newer.

Note You need to log in before you can comment on or make changes to this bug.