Bug 815033 - rpmbuild : no suitable Python interpreter found
rpmbuild : no suitable Python interpreter found
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: build (Show other bugs)
1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On: GLUSTER-2925
Blocks: 811632
  Show dependency treegraph
 
Reported: 2012-04-22 03:19 EDT by Scott Haines
Modified: 2015-01-22 10:29 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: GLUSTER-2925
Environment:
Last Closed: 2012-05-01 07:17:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Haines 2012-04-22 03:19:34 EDT
+++ This bug was initially created as a clone of Bug #764657 +++

The problem now is :

Obsoletes: glusterfs-client < 3.1.0
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/glusterfs-3.2.0-1-root
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/glusterfs-3.2.0-1-root


RPM build errors:
    cannot open Pubkeys index using db3 - No such file or directory (2)
    File not found: /var/tmp/glusterfs-3.2.0-1-root/etc/init.d/glusterd

--- Additional comment from i.r.1783@gmx.net on 2011-05-22 13:00:13 EDT ---

Created attachment 496

--- Additional comment from i.r.1783@gmx.net on 2011-05-22 15:51:02 EDT ---

My buildmachine is a opensuse 11.4 64bit box.
I build for SLES11SP1.
I have following error when I call
build --clean --rpms /mnt/iso1:/mnt/iso2:/mnt/iso3 --dist sles11 --arch x86_64 --root /tmp/gluster320 glusterfs.spec

checking for a Python interpreter with version >= 2.4... none
configure: error: no suitable Python interpreter found
error: Bad exit status from /var/tmp/rpm-tmp.44682 (%build)


RPM build errors:
    cannot open Pubkeys index using db3 - No such file or directory (2)
    Bad exit status from /var/tmp/rpm-tmp.44682 (%build)


I added within glusterfs.spec a new subjection:

BuildRequires: python-devel

After that the buildenvironment is correct and it starts compiling.

--- Additional comment from lakshmipathi@gluster.com on 2011-07-26 05:40:30 EDT ---

Thanks will add python-devel to build requires. Could you please attach the glusterfs.spec file generated for open suse?

--- Additional comment from i.r.1783@gmx.net on 2011-07-26 08:32:59 EDT ---

Created attachment 587

--- Additional comment from amarts@redhat.com on 2011-10-25 00:00:45 EDT ---

I see that these changes are already in master branch glusterfs.spec file. Please re-open if there are any issues.

--- Additional comment from i.r.1783@gmx.net on 2011-10-29 16:45:42 EDT ---

sorry, but i cannot see these changes within the release of
3.1.7 and 3.2.4

--- Additional comment from fharshav@redhat.com on 2011-11-07 15:34:48 EST ---

(In reply to comment #6)
> sorry, but i cannot see these changes within the release of
> 3.1.7 and 3.2.4

A patch has been submitted for this.

--- Additional comment from aavati@redhat.com on 2011-11-23 20:51:59 EST ---

CHANGE: http://review.gluster.com/684 (Change-Id: I8adb8d63b0c219d214a6d4cb1d3e12d4d5bc0b2b) merged in release-3.2 by Anand Avati (avati@gluster.com)

--- Additional comment from aavati@redhat.com on 2011-11-23 20:53:45 EST ---

CHANGE: http://review.gluster.com/729 (Change-Id: I4ccf75288aad6d5f210bd7c51c0ce9924bb0efad) merged in master by Anand Avati (avati@gluster.com)
Comment 3 errata-xmlrpc 2012-05-01 07:17:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0538.html

Note You need to log in before you can comment on or make changes to this bug.