Bug 815039 - Cleanup before exiting when assert_on_child_down is enabled
Cleanup before exiting when assert_on_child_down is enabled
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: shishir gowda
:
Depends On: 783249
Blocks: 811632
  Show dependency treegraph
 
Reported: 2012-04-22 03:20 EDT by Scott Haines
Modified: 2015-01-22 10:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 783249
Environment:
Last Closed: 2012-05-01 07:18:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Haines 2012-04-22 03:20:39 EDT
+++ This bug was initially created as a clone of Bug #783249 +++

Description of problem:

When assert_on_child_down is enabled, glusterfs process exits without providing an opportunity to do cleanup before exiting. This needs to be corrected.

Version-Release number of selected component (if applicable):
3.2.5

How reproducible:
Always

Steps to Reproduce:
1. Enable assert_on_child_down in dht
2. Bring a brick down

  
Actual results:

A stale client mount is seen

Expected results:

Stale client mount should not be seen
Additional info:

--- Additional comment from aavati@redhat.com on 2012-01-24 11:36:41 EST ---

CHANGE: http://review.gluster.com/2682 (cluster/dht: Exit clean when assert_no_child_down is enabled) merged in release-3.2 by Anand Avati (avati@gluster.com)

--- Additional comment from shmohan@redhat.com on 2012-02-17 04:18:04 EST ---

1. Created a distribute volume with 3 bricks
2. mounted using the command "/opt/glusterfs/3.2.6qa3/sbin/glusterfs --log-level=INFO --xlator-option=dist*.assert-no-child-down=yes --volfile-id=/dist --volfile-server=10.1.11.117 /mnt"
3. cd /mnt
4. killed one of the brick
5. cd /
6. client was automatically unmounted


Marking as verified

--- Additional comment from aavati@redhat.com on 2012-02-19 04:42:54 EST ---

CHANGE: http://review.gluster.com/2664 (cluster/dht: Exit clean when assert_no_child_down is enabled) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 3 errata-xmlrpc 2012-05-01 07:18:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0538.html

Note You need to log in before you can comment on or make changes to this bug.