Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 815047 - Kmail not fetching/showing emails until akonadi restarted after disconnecting with network.
Summary: Kmail not fetching/showing emails until akonadi restarted after disconnecting...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdepimlibs
Version: 17
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-22 08:10 UTC by Nikolai Maziashvili
Modified: 2012-12-07 11:53 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-01 09:51:55 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 300086 0 'NOR' 'RESOLVED' 'Kmail goes crazy after system suspend (online/offline modes)' 2019-11-11 13:39:38 UTC

Description Nikolai Maziashvili 2012-04-22 08:10:53 UTC
Description of problem:
When out of suspend i need to restart akonadi to make Kmail fetch emails. All emails are present in view, but when i try to view older email (not cached) i can't, until i restart akonadi.
First i thought it was Kmail, since i had problems with it in the past - not being able to reconnect to network after loosing connection. But now it is seems akonadi to be at fault. 

Version-Release number of selected component (if applicable):
kmail - 4.8.2
akonadi - 1.7.2

How reproducible:
every time


Steps to Reproduce:
1. Set up imap mail account on kmail.
2. Suspend laptop for a minute.
3. Wake it up and try to view old email messages or fetch new ones for that matter. Just send e test email to your account to see if Kmail fetches it.
  
Actual results:
New mails not "arriving", old (not cached) emails can not be read.

Expected results:


Additional info:

Comment 1 Nikolai Maziashvili 2012-04-28 10:39:55 UTC
I don't know if it is relevant but starting kmail from konsole gives me following messages:

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
loaded the Generic plugin 
kmail2(5372)/kdepimlibs (mailtransport): Could not access Outbox.

Comment 2 Nikolai Maziashvili 2012-09-16 19:44:47 UTC
Works in F17/KDE4.9.

Comment 3 Rex Dieter 2012-11-26 16:17:59 UTC
looks like there's even more related fixes on the way...

http://commits.kde.org/kdepimlibs/5a3856c2e51f4b11ec374b3ad4214ae008e1be5e

Comment 4 Fedora Update System 2012-11-26 17:11:54 UTC
kdepimlibs-4.9.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kdepimlibs-4.9.3-2.fc18

Comment 5 Fedora Update System 2012-11-26 17:12:52 UTC
kdepimlibs-4.9.3-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kdepimlibs-4.9.3-2.fc17

Comment 6 Fedora Update System 2012-11-27 09:47:41 UTC
Package kdepimlibs-4.9.3-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdepimlibs-4.9.3-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19083/kdepimlibs-4.9.3-2.fc18
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-12-01 09:51:57 UTC
kdepimlibs-4.9.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2012-12-06 07:08:29 UTC
kdepimlibs-4.9.3-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Nikolai Maziashvili 2012-12-07 11:53:38 UTC
I had a feeling that it was working already in latest KDE4.9. Anyway, just updated, did a quick test (offline/online) - seems all fine to me.
thnx guys.


Note You need to log in before you can comment on or make changes to this bug.