Bug 815116 - gpgme.h: fatal error: gpgme-i386.h: No such file or directory compilation terminated.
gpgme.h: fatal error: gpgme-i386.h: No such file or directory compilation ter...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gpgme (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-22 12:12 EDT by Mads Kiilerich
Modified: 2012-06-01 12:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-01 12:55:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2012-04-22 12:12:43 EDT
$ echo '#include "gpgme.h"' > test.c && gcc test.c 
In file included from test.c:1:0:
/usr/include/gpgme.h:14:24: fatal error: gpgme-i386.h: No such file or directory
compilation terminated.

$ rpm -qf /usr/include/gpgme.h
gpgme-devel-1.3.0-6.fc17.i686

$ rpm -qlf /usr/include/gpgme.h|grep include
/usr/include/gpgme-i686.h
/usr/include/gpgme.h

$ grep i.86 /usr/include/gpgme.h
#if defined(__i386__)
#include "gpgme-i386.h"


Both __i386 and __i686__ is defined. Patching gpgme.h so it starts with a 686 sections brings it one step further but fails with
/usr/include/gpgme-i686.h:95:2: error: #error GPGME was compiled with _FILE_OFFSET_BITS = 64, please see the section "Largefile support (LFS)" in the GPGME manual.

I guess this problem might cause some FTBFS packages on i686.
Comment 1 Rex Dieter 2012-04-22 12:21:34 EDT
OK, seen similar issues on other multilib hacks, I can apply the same fix here.
Comment 2 Rex Dieter 2012-04-22 12:42:01 EDT
Fwiw, the latter problem is a separate one, in that apps that use gpgme are expected to be built using the same value of _FILE_OFFSET_BITS as gpgme was built with.
Comment 3 Rex Dieter 2012-04-22 19:58:09 EDT
Try out this build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4013881
Comment 4 Mads Kiilerich 2012-04-22 21:02:07 EDT
Yes, that works for me.

(Except for the LFS issue which probably is caused by package I was building - bazaar-1.4.2-14 (without docs) resurrected from the land of the orphans. Brutally and naively removing the warning from gpgme-32.h worked good enough for this experiment.)
Comment 5 Fedora Update System 2012-04-22 21:13:46 EDT
gpgme-1.3.0-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-1726/gpgme-1.3.0-8.fc17
Comment 6 Fedora Update System 2012-04-23 23:18:17 EDT
Package gpgme-1.3.0-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gpgme-1.3.0-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1726/gpgme-1.3.0-8.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-06-01 12:55:14 EDT
gpgme-1.3.0-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.