Bug 815136 - libvirt should support some sort of 'ipmi server'
libvirt should support some sort of 'ipmi server'
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-22 15:32 EDT by purpleidea
Modified: 2016-10-28 12:53 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 17:18:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description purpleidea 2012-04-22 15:32:48 EDT
Description of problem:

It would be especially convenient if libvirt supported some sort of 'ipmi server' so that sysadmins could plug kvm hosts and others into their existing ipmi management infrastructure.

Via ipmitool we would then be able to get virsh consoles, power status and so on.


Additional info:

There are probably some issues such as how would this work when a virtual machines migrates to a different host? My recommended solution would be to simply have the ipmi run on the primary virtual IP that is supporting the cluster and always connect to that when looking for your host. When the VM moves, so does the IP, and ipmi always goes to the right place.

Thanks in advance!
Comment 1 Dave Allan 2012-04-23 12:23:05 EDT
In general, some of libvirt's functionality could probably be made to work through IPMI, so if you're interested in submitting patches, you should take this up on the mailing list.  It's a tremendous amount of work, though, and I'm unsure of what limitations there are on implementing IPMI.  You'd want to confirm that there aren't any licensing limitations before you start.

One caveat wrt migration: libvirt is explicitly a single node management api so if you really need IPMI to work with migration, you would need to write a stand-alone daemon that implements the IPMI interface and talks to multiple hosts.  IMO, a stand-alone daemon is probably the right approach in any case, rather than trying to bundle this functionality into libvirt itself, but that's just my $.02.

None of that is meant to discourage you--it's a cool idea and you should raise it on the upstream list if you think you could implement it.  I'm sure you'd get some good feedback.
Comment 2 purpleidea 2012-04-30 14:14:54 EDT
Hi Dave,

I appreciate the comments!
The licensing issue (if there is one) didn't even occur to me :(

My plate is kind of full for the upcoming while, so if it's okay, I'll leave this idea here as a seed, and maybe it will grow. -- Sorry for not sticking this on the mailing list first, I figured the libvirt people were using mostly this bugzilla anyways.

Thank you!
James
Comment 3 Cole Robinson 2016-03-23 17:18:12 EDT
Since this seed never really grew, keeping this bug open doesn't accomplish much except add mass to the bug list. closing

Note You need to log in before you can comment on or make changes to this bug.