Bug 815179 - [abrt] bluefish-2.2.2-1.fc17: __GI_raise: Process /usr/bin/bluefish was killed by signal 6 (SIGABRT)
[abrt] bluefish-2.2.2-1.fc17: __GI_raise: Process /usr/bin/bluefish was kille...
Status: CLOSED DUPLICATE of bug 770194
Product: Fedora
Classification: Fedora
Component: bluefish (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
abrt_hash:0c0d8fd58f9bc0246532c4101d3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-22 23:41 EDT by Guillaume Poirier-Morency
Modified: 2012-04-25 08:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 08:29:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (25.90 KB, text/plain)
2012-04-22 23:41 EDT, Guillaume Poirier-Morency
no flags Details
File: maps (45.70 KB, text/plain)
2012-04-22 23:41 EDT, Guillaume Poirier-Morency
no flags Details
File: dso_list (10.28 KB, text/plain)
2012-04-22 23:41 EDT, Guillaume Poirier-Morency
no flags Details

  None (edit)
Description Guillaume Poirier-Morency 2012-04-22 23:41:51 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        bluefish
comment:        Bluefish was prompting for saving documents as I was quitting it. It was unresponsive to the cancel button. I hope it's not related to the file choosing window.
crash_function: __GI_raise
executable:     /usr/bin/bluefish
kernel:         3.3.2-8.fc17.x86_64
pid:            3931
pwd:            /home/guillaume-pm
remote_result:  770194
time:           dim 22 avr 2012 23:23:18 EDT
uid:            1000
username:       guillaume

backtrace:      Text file, 26517 bytes
dso_list:       Text file, 10523 bytes
maps:           Text file, 46792 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/guillaume/2

core_backtrace:
:11d196ee9220c6039404f4ba675abf3a24d8f0aa 0x35915 raise libc.so.6 -
:11d196ee9220c6039404f4ba675abf3a24d8f0aa 0x370c8 abort libc.so.6 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x68837 g_assertion_message libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x68d54 g_assertion_message_expr libglib-2.0.so.0 -
:451ba2ad8accacf11ddc2946f8512e9fbb72b2c0 0x13c588 - libgtk-3.so.0 -
:451ba2ad8accacf11ddc2946f8512e9fbb72b2c0 0x13daae - libgtk-3.so.0 -
:451ba2ad8accacf11ddc2946f8512e9fbb72b2c0 0x13db30 - libgtk-3.so.0 -
:647c8183274c4626c81e86e7a631a81782a04e65 0x6ce47 g_simple_async_result_complete libgio-2.0.so.0 -
:647c8183274c4626c81e86e7a631a81782a04e65 0x6cec8 - libgio-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x475cc g_main_context_dispatch libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x479e8 - libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x47de2 g_main_loop_run libglib-2.0.so.0 -
:451ba2ad8accacf11ddc2946f8512e9fbb72b2c0 0x10a3af gtk_dialog_run libgtk-3.so.0 -
:245ff58efdc32bf8ab314e3ab8e76192b67614f4 0x5542a ask_new_filename [exe] -
:245ff58efdc32bf8ab314e3ab8e76192b67614f4 0x55853 doc_save_backend [exe] -
:245ff58efdc32bf8ab314e3ab8e76192b67614f4 0x55caf doc_save_all_close [exe] -
:245ff58efdc32bf8ab314e3ab8e76192b67614f4 0x35705 bfwin_delete_event [exe] -
:451ba2ad8accacf11ddc2946f8512e9fbb72b2c0 0x17a5ef - libgtk-3.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0xf943 - libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0x27d88 g_signal_emit_valist libgobject-2.0.so.0 -
:d50284b66d63e0cc3f25b4c2ea9e7476d82ec292 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:451ba2ad8accacf11ddc2946f8512e9fbb72b2c0 0x2a266e - libgtk-3.so.0 -
:451ba2ad8accacf11ddc2946f8512e9fbb72b2c0 0x17a3f0 gtk_main_do_event libgtk-3.so.0 -
:2a34337df68bcebcf471d5e3362ac137ffea4527 0x48e12 - libgdk-3.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x475cc g_main_context_dispatch libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x479e8 - libglib-2.0.so.0 -
:8568e11bef79abaf14513d18a8559282d8dad34a 0x47de2 g_main_loop_run libglib-2.0.so.0 -
:451ba2ad8accacf11ddc2946f8512e9fbb72b2c0 0x179585 gtk_main libgtk-3.so.0 -
:245ff58efdc32bf8ab314e3ab8e76192b67614f4 0x1ecea main [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=guillaume-fedora-pc
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/run/user/guillaume/keyring-ieAEeD
:IMSETTINGS_MODULE=none
:USER=guillaume
:USERNAME=guillaume
:MAIL=/var/spool/mail/guillaume
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/guillaume-pm
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1501
:LANG=fr_CA.utf8
:GDM_LANG=fr_CA.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/guillaume-pm
:SHLVL=1
:LOGNAME=guillaume
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-FBogACqO28,guid=766a1b4ebd9f28725d8314b2000003b3
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/guillaume
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-guillaume-vgpdq6/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1506,unix/unix:/tmp/.ICE-unix/1506
:GPG_AGENT_INFO=/run/user/guillaume/keyring-ieAEeD/gpg:0:1
:SSH_AUTH_SOCK=/run/user/guillaume/keyring-ieAEeD/ssh
:LC_TIME=fr_CA.utf8
:LC_NUMERIC=fr_CA.utf8
:LC_MONETARY=fr_CA.utf8
:LC_MEASUREMENT=fr_CA.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/bluefish.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=3931
:DESKTOP_STARTUP_ID=gnome-shell-1729-guillaume-fedora-pc-bluefish-4_TIME1278386

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 63732                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       63732                63732                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/guillaume-pm/.xsession-errors
:pos:	1499386
:flags:	0102002
:2:/home/guillaume-pm/.xsession-errors
:pos:	1499386
:flags:	0102002
:3:socket:[33776]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[35466]
:pos:	0
:flags:	02004002
:6:socket:[33779]
:pos:	0
:flags:	02
:7:socket:[37216]
:pos:	0
:flags:	02004002
:8:anon_inode:inotify
:pos:	0
:flags:	02004000
:9:/home/guillaume-pm/.local/share/gvfs-metadata/home
:pos:	0
:flags:	0100000
:10:/home/guillaume-pm/.local/share/gvfs-metadata/home-87cb5ce8.log
:pos:	0
:flags:	0100000
:11:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:12:socket:[64369]
:pos:	0
:flags:	02004002
:13:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:14:anon_inode:[eventfd]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:Général
:=================================
:UUID: 5c3898b2-3b97-4b75-975d-f5b27022d554
:SE: Fedora release 17 (Beefy Miracle)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_CA.utf8
:Plateforme: x86_64
:BogoMIPS: 5999.21
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM)2 Extreme CPU X9650  @ 3.00GHz
:Stepping du processeur: 7
:Famille de processeur: 6
:Modèle du processeur: 23
:Nombre de processeurs: 4
:Vitesse du processeur: 3000
:Mémoire du système: 7986
:Swap du système: 997
:Fabricant: Gigabyte Technology Co., Ltd.
:Système: X38-DQ6 
:Type d'ordinateur: Desktop
:Noyau: 3.3.2-8.fc17.x86_64
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Terra.1680.1050
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(32902:10729:5208:20480) pci, pcieport, PCI/PCI, 82X38/X48 Express Host-Secondary PCI Express Bridge
:(32902:10720:5208:20480) pci, x38_edac, HOST/PCI, 82X38/X48 Express DRAM Controller
:(32902:10721:5208:20480) pci, pcieport, PCI/PCI, 82X38/X48 Express Host-Primary PCI Express Bridge
:(6164:1921:4163:4879) pci, rt2800pci, NETWORK, RT2860
:(32902:10544:5208:20481) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10528:5208:45058) pci, ata_piix, STORAGE, 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller
:(32902:10518:5208:20481) pci, None, PCI/ISA, 82801IR (ICH9R) LPC Interface Controller
:(32902:10534:5208:45058) pci, ata_piix, STORAGE, 82801I (ICH9 Family) 2 port SATA IDE Controller
:(32902:9294:5208:20480) pci, None, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:10549:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:5208:20486) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:5208:20486) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(5361:34898:112:30993) pci, cx23885, MULTIMEDIA_VIDEO, CX23885 PCI Video and Audio Decoder
:(32902:10564:5208:20481) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(32902:10566:5208:20481) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10560:5208:20481) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10568:5208:20481) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:5208:40994) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:(32902:10551:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4318:1557:6618:4355) pci, nvidia, VIDEO, G92 [GeForce GTS 250]
:(32902:10570:5208:20481) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 6
:(4172:32804:5208:4096) pci, firewire_ohci, FIREWIRE, GA-EP45-DS5 Motherboard
:(6523:9059:5208:45056) pci, pata_jmicron, STORAGE, GA-EP45-DS5 Motherboard
:(6523:9059:5208:45056) pci, ahci, STORAGE, GA-EP45-DS5 Motherboard
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 4874987 2561165 2512349 1220608 985880 985880
:/dev/sdb WITHHELD ext4 4096 4096 487910848 437659338 413240406 122101760 122057706 122057706
:/dev/sda2 /home ext4 4096 4096 14372248 6400331 5680378 3604480 3246101 3246101
:

var_log_messages:
:Apr 22 23:01:29 guillaume-fedora-pc yum[3404]: Installed: bluefish-shared-data-2.2.2-1.fc17.noarch
:Apr 22 23:01:31 guillaume-fedora-pc yum[3404]: Installed: bluefish-2.2.2-1.fc17.x86_64
:Apr 22 23:23:20 guillaume-fedora-pc abrt[5255]: Saved core dump of pid 3931 (/usr/bin/bluefish) to /var/spool/abrt/ccpp-2012-04-22-23:23:18-3931 (122028032 bytes)

xsession_errors:
:Language statistics for Javascript from /usr/share/bluefish/bflang//javascript.bflang2
:Language statistics for XHTML from /usr/share/bluefish/bflang//xhtml.bflang2
:Language statistics for PHP from /usr/share/bluefish/bflang//php.bflang2
:** (bluefish:3931): CRITICAL **: enchant_dict_check: assertion `len' failed
:** (bluefish:3931): CRITICAL **: enchant_dict_check: assertion `len' failed
:** (bluefish:3931): CRITICAL **: enchant_dict_check: assertion `len' failed
:** (bluefish:3931): CRITICAL **: enchant_dict_check: assertion `len' failed
:** (bluefish:3931): CRITICAL **: enchant_dict_check: assertion `len' failed
:** (bluefish:3931): CRITICAL **: enchant_dict_check: assertion `len' failed
:(bluefish:3931): Gtk-CRITICAL **: gtk_device_grab_add: assertion `GDK_IS_DEVICE (device)' failed
:(bluefish:3931): Gdk-CRITICAL **: gdk_device_grab: assertion `GDK_IS_DEVICE (device)' failed
:Language statistics for PHP from /usr/share/bluefish/bflang//php.bflang2
:Language statistics for PHP from /usr/share/bluefish/bflang//php.bflang2
Comment 1 Guillaume Poirier-Morency 2012-04-22 23:41:54 EDT
Created attachment 579402 [details]
File: backtrace
Comment 2 Guillaume Poirier-Morency 2012-04-22 23:41:56 EDT
Created attachment 579403 [details]
File: maps
Comment 3 Guillaume Poirier-Morency 2012-04-22 23:41:57 EDT
Created attachment 579404 [details]
File: dso_list
Comment 4 Paul Howarth 2012-04-25 08:29:40 EDT
I think this one's a gtk3 bug, given the very similar backtrace to Bug #770194.

*** This bug has been marked as a duplicate of bug 770194 ***

Note You need to log in before you can comment on or make changes to this bug.