Bug 815255 - Installation of package maven2-plugin-plugin fail
Installation of package maven2-plugin-plugin fail
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.8
i386 Linux
unspecified Severity high
: rc
: ---
Assigned To: James Antill
BaseOS QE Security Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 04:26 EDT by BERNIER Matthias
Modified: 2014-01-21 01:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-23 08:39:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Complete log of the yum install maven2-plugin-plugin command (launched after the download of the packages) (50.90 KB, application/octet-stream)
2012-04-23 04:27 EDT, BERNIER Matthias
no flags Details

  None (edit)
Description BERNIER Matthias 2012-04-23 04:26:30 EDT
Description of problem:

When trying to install the maven2-plugin-plugin package with yum on CentOS 5.5 i386, the following output is obtained after the rpm_check_debug process of yum : 

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by aspectj-1.5.4-1.jpp6.noarch
rpmlib(FileDigests) is needed by rhino-1.7-1.r2.8.jpp6.noarch
rpmlib(FileDigests) is needed by saxon9-dom-B.9.0.0.8-2.jpp6.noarch
rpmlib(FileDigests) is needed by easymock2-2.5.2-2.jpp6.noarch
rpmlib(FileDigests) is needed by saxon9-B.9.0.0.8-2.jpp6.noarch
rpmlib(FileDigests) is needed by saxon9-xpath-B.9.0.0.8-2.jpp6.noarch
rpmlib(FileDigests) is needed by xmlbeans-2.4.0-3.jpp6.noarch
rpmlib(FileDigests) is needed by jtidy-7.0-0.V04aug2000r7_dev.2.jpp6.noarch
rpmlib(FileDigests) is needed by plexus-container-default-1.0-0.a9s1.2.jpp6.noarch
rpmlib(FileDigests) is needed by lucene-2.4.1-5.jpp6.noarch
rpmlib(FileDigests) is needed by aqute-bndlib-0.0.363-1.jpp6.noarch
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])


Version-Release number of selected component (if applicable):

[root@VM010223008171 ~]# yum --version
3.2.22
  Installed: rpm-4.4.2.3-18.el5.i386 at 2010-10-12 09:17
  Built    : [] at 2009-09-04 00:26
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2009-07-24 22:00

  Installed: yum-3.2.22-26.el5.centos.noarch at 2010-10-12 09:18
  Built    : [] at 2010-04-04 19:48
  Committed: Karanbir Singh <kbsingh@centos.org> at 2010-04-04 22:00

  Installed: yum-metadata-parser-1.1.2-3.el5.centos.i386 at 2010-10-12 09:16
  Built    : [] at 2009-08-27 16:20
  Committed: James Antill <james.antill@redhat.com> at 2009-04-06 22:00


How reproducible:

Launch the following command (needs to have the JPackage 6.0 repository enabled) :

yum install maven2-plugin-plugin


Steps to Reproduce:
1. Add the JPackage repository ( rpm -ivh http://mirrors.dotsrc.org/jpackage/6.0/generic/free/RPMS/jpackage-release-6-3.jpp6.noarch.rpm)

2. Launch the yum install maven2-plugin-plugin command.
  
Actual results:

Unable to install maven2-plugin-plugin package (and also to install maven22 package for this reason).

Expected results:

Installation of maven2-plugin-plugin package without this error message

Additional info:
Comment 1 BERNIER Matthias 2012-04-23 04:27:05 EDT
Created attachment 579450 [details]
Complete log of the yum install maven2-plugin-plugin command (launched after the download of the packages)
Comment 2 James Antill 2012-04-23 08:39:29 EDT
 This is rpm telling you that you need a newer version of rpm to install the given pacakges.

 At a guess the root problem is that it looks like you are trying to install RHEL-6 packages on RHEL-5.

Note You need to log in before you can comment on or make changes to this bug.