Bug 81526 - redhat-config-packages fails with segfault error.
redhat-config-packages fails with segfault error.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-09 22:43 EST by Larry Troan
Modified: 2016-04-18 05:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 00:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Troan 2003-01-09 22:43:07 EST
redhat-config-packages fails with segfault error.

Operating System: RedHat 8.1 Beta 3.

Details:
Server (and Generation): All

Steps to reproduce:
1) # redhat-configure-packages
2) Multiple errors in MainWindow.py are reported, such as "invalid
uninstantiatable type", "assertion failure G_TYPE_CHECK_INSTANCE", etc.

Is the issue reproducible? Yes
----------
Action by: Bryan.Leopard
Issue Registered


THIS IS ISSUE TRACKER 13273.
Comment 1 Jeremy Katz 2003-01-09 22:48:00 EST

*** This bug has been marked as a duplicate of 80283 ***
Comment 2 Larry Troan 2003-02-02 21:55:51 EST
NOTE FROM HP VIA ISSUE TRACKER 13273....
Fails in beta4, but differently from Beta 3.  Now fails after the list of
installed packages comes up, then you uncheck one of the packages you don't
need, say "Gnome Software Development" after an "Everything" installation. 
Click on Update, an error is reported on line 55 of /usr/share/redhat-config
packages/method.py: Exception: __init__()
Comment 3 Jeremy Katz 2003-02-09 20:49:55 EST
Fixed in cvs and will be in 1.1.6-1
Comment 4 Larry Troan 2003-03-13 21:36:33 EST
FROM ISSUE TRACKER
Event posted 03-10-2003 12:21pm by Bryan.Leopard with duration of 0.00
Fails when removing packages (beta 5). 
Comment 5 Larry Troan 2003-03-27 22:32:30 EST
FROM ISSUE TRACKER
Event posted 03-25-2003 03:49pm by Bryan.Leopard with duration of 0.00
 Still a problem in the GM product.
Comment 6 John Thacker 2006-04-22 00:24:38 EDT
Long fixed, RH 9 not supported except by Fedora Legacy, and s-c-p isn't shipped
anymore.  (Pirut replaced s-c-p.)  Closing.

Note You need to log in before you can comment on or make changes to this bug.