Bug 815282 - Bug in auto-possessifying characters from 127-255 range in non-unicode mode
Bug in auto-possessifying characters from 127-255 range in non-unicode mode
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcre (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Pisar
Lukas Zachar
https://lists.exim.org/lurker/message...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 05:35 EDT by Petr Pisar
Modified: 2014-06-12 04:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: pcre-8.21-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 815217
Environment:
Last Closed: 2014-06-12 04:37:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-04-23 05:35:54 EDT
+++ This bug was initially created as a clone of Bug #815217 +++

This should match:

/\w+\x{C4}/8BZT1
a\x{C4}\x{C4}

But it does not because a some tests in non-unicode mode checks only for characters with ordinal numbers 0-127 instead of 0-255.

This is fixed in upstream commit:

r962 | ph10 | 2012-04-20 19:28:23 +0200 (PĆ”, 20 dub 2012) | 3 lines
Fix auto-possessifying bugs when PCRE_UCP is not set, but character tables 
specify characters in the range 127-255 are letters, spaces, etc.

All Fedoras affected.

--- Additional comment from ppisar@redhat.com on 2012-04-23 08:03:49 GMT ---

Fixed as pcre-8.30-5.fc18 in F18.

--- Additional comment from updates@fedoraproject.org on 2012-04-23 08:52:10 GMT ---

pcre-8.21-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/pcre-8.21-5.fc17

-----
RHEL-7 (pcre-8.21-4.el7.x86_64) affected.

Note You need to log in before you can comment on or make changes to this bug.