Bug 815301 - GRUB doesn't install to root partition
GRUB doesn't install to root partition
Status: CLOSED DUPLICATE of bug 804835
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 06:20 EDT by gerfert
Modified: 2012-04-23 06:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-23 06:51:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description gerfert 2012-04-23 06:20:19 EDT
Description of problem:

When I try to install either Fedora 17 Beta or RFRemix 17 Beta GRUB doesn't install to the root partition. 

XFCE spin for both editions, x86_64


How reproducible:
Choose installing bootloader to new fedora root partition (http://en.zimagez.com/zimage/-23042012-154455.php)
RFRemix installer said there was a problem in bootloader installation, whereas Fedora's one makes no notice.
  
Actual results:
After chainloading I see GRUB error
'invalid signature' with RFRemix installed and just a string 'GRUB' with original Fedora installed. In the latter case there is blinking cursor that doesn't respond to keyboard

Expected results:
GRUB from MBR should link to Fedora's GRUB via chainloading.

Additional info:
I tried to use chroot to fix that under live-usb Fedora and gentoo-based distro

results for Fedora:

# mount /dev/sda7 /mnt/rfr
# mount -t proc none /mnt/rfr/proc
# mount -o bind /dev /mnt/rfr/dev
# mount -o bind /sys /mnt/rfr/sys
# grub2-install /dev/sda7
/sbin/grub2-bios-setup: warning: File system `ext2' doesn't support embedding.
/sbin/grub2-bios-setup: warning: Embedding is not possible.  GRUB can only be
installed in this setup by using blocklists.  However, blocklists are UNRELIABLE
and their use is discouraged..
/sbin/grub2-bios-setup: error: will not proceed with blocklists.
# grub2-install /dev/sda7 --force
/sbin/grub2-bios-setup: warning: File system `ext2' doesn't support embedding.
/sbin/grub2-bios-setup: warning: Embedding is not possible.  GRUB can only be
installed in this setup by using blocklists.  However, blocklists are UNRELIABLE
and their use is discouraged..
Installation finished. No error reported.
# grub2-install  --boot-directory=/boot --force '(hd0,7)'
/sbin/grub2-bios-setup: warning: File system `ext2' doesn't support embedding.
/sbin/grub2-bios-setup: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
Installation finished. No error reported.

==================================
I have the following partition:

/dev/sda1 and /dev/sda2 are for Windows.
/dev/sda3 is not used
/dev/sda4 is extended partition
/dev/sda5 Ubuntu
/dev/sda6 Calculate Linux 
/dev/sda7 <-- Fedora is installed here
/dev/sda8 is /home partition

There is Calculate's GRUB2 bootloader in MBR. Chainloading works well for linking to Ubuntu, the Ubuntu's GRUB is stored in its own partition and it works fine. I try to do the same thing with Fedora installation but the problem occurs.

# fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, всего 1953525168 секторов
Units = секторы of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xe3b23936

Устр-во Загр     Начало       Конец       Блоки   Id  Система
/dev/sda1            2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   163839999    81816576    7  HPFS/NTFS/exFAT
/dev/sda3       163840000   164966399      563200   83  Linux
/dev/sda4       164966400  1953525167   894279384    5  Расширенный
/dev/sda5       164968448   205928447    20480000   83  Linux
/dev/sda6       205930496   246890495    20480000   83  Linux
/dev/sda7   *   246892544   287852543    20480000   83  Linux
/dev/sda8       287854592  1953523711   832834560   83  Linux
Comment 1 gerfert 2012-04-23 06:31:12 EDT
I've made mistake above

/dev/sda5 (btrfs) Calculate Linux 
/dev/sda6 (ext4) Ubuntu 
/dev/sda7 (ext4) Fedora
/dev/sda8 (ext4) /home


Here is custom chainloading GRUB file used in main GRUB menu:

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

menuentry "Ubuntu on /dev/sda6" {
set root=(hd0,6)
chainloader +1
}
menuentry "RFRemix on /dev/sda7" {
set root=(hd0,7)
chainloader +1
}
Comment 2 Mads Kiilerich 2012-04-23 06:51:32 EDT

*** This bug has been marked as a duplicate of bug 804835 ***

Note You need to log in before you can comment on or make changes to this bug.