Bug 815309 - [Doc]Some incorrect steps in the " 9.2 Installing the Windows Balloon driver "
[Doc]Some incorrect steps in the " 9.2 Installing the Windows Balloon driver "
Status: CLOSED DUPLICATE of bug 752738
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Virtualization_Host_Configuration_and_Guest_Installation_Gui (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Dayle Parker
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 06:39 EDT by hongming
Modified: 2012-05-10 01:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 01:29:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
actual results (123.03 KB, image/png)
2012-04-23 06:47 EDT, hongming
no flags Details
Expected result 01 (155.65 KB, image/png)
2012-04-23 06:50 EDT, hongming
no flags Details
Expected result 02 (145.56 KB, image/png)
2012-04-23 06:51 EDT, hongming
no flags Details
Expected result 03 (149.55 KB, image/png)
2012-04-23 06:52 EDT, hongming
no flags Details

  None (edit)
Description hongming 2012-04-23 06:39:58 EDT
Description of problem:
There are three incorrect steps  in the section "9.2 Installing the Windows Balloon driver" of Virtualization Host Configuration and Guest Installation Guide.
http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Virtualization_Host_Configuration_and_Guest_Installation_Guide/ch09s02.html

Version-Release number of selected component (if applicable):
virtualization Document Edition 0.2

How reproducible:
100% 

Steps to Reproduce:
1.
2.
3.
  
Actual results:

1. Install the virtio-win package, either directly from RHN or through the yum packaging system.
2. Mount the /usr/share/virtio-win/virtio-win.iso file as a CD-ROM to the Windows virtual machine.
3. Copy the Ballon\ directory from the mounted CD-ROM to the system drive (C:\).
4. Download the devcon.exe utility for your system architecture by following the instructions at this URL: http://social.technet.microsoft.com/wiki/contents/articles/how-to-obtain-the-current-version-of-device-console-utility-devcon-exe.aspx. Then, copy it to C:\Balloon\2k8\x86 or C:\Balloon\2k8\x64, depending on your system architecture.
5. Open a command terminal. Navigate to the location of the devcon utility and run the following command:
      devcon install BALLOON.inf "PCI\VEN_1AF4&DEV_1002&SUBSYS_00051AF4&REV_00"
6. Restart Windows for changes to take effect.

According above guidance (step3 ~ step5) , user can't successfully install virtio ballon driver.


Expected results:

1. Install the virtio-win package, either directly from RHN or through the yum packaging system.
2. Mount the /usr/share/virtio-win/virtio-win.iso file as a CD-ROM to the Windows virtual machine.
3. Open Device Manager in  windows virtual machine and Select the  PCI standard RAM Controller below System devices.
4. Right-click Update Driver Software... and click Browse my computer for driver software , then select the correct location(e.g. E:/Balloon/w7/amd64) from the mounted CD-ROM according to your guest os information and click next.
5. After the driver is installed successfully ,click OK.  The VirtIO Balloon Driver will occurs below System
6. Restart Windows for changes to take effect.  


Additional info:
Comment 1 hongming 2012-04-23 06:47:56 EDT
Created attachment 579486 [details]
actual results
Comment 2 hongming 2012-04-23 06:50:21 EDT
Created attachment 579489 [details]
Expected result 01
Comment 3 hongming 2012-04-23 06:51:20 EDT
Created attachment 579490 [details]
Expected result 02
Comment 5 hongming 2012-04-23 06:52:04 EDT
Created attachment 579494 [details]
Expected result 03
Comment 7 Dayle Parker 2012-05-10 01:29:04 EDT
Hi Hongming,

This section was included in erroneously in this document, and will be removed as part of the update to Red Hat Enterprise Linux 6.3.

The procedures in the 6-Beta documentation, specifically the sections 10.2, "Installing the drivers on an installed Windows guest", and 10.3, "Installing drivers during the Windows installation" should hopefully solve the issue.

Please refer to these links for the procedures:

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6-Beta/html/Virtualization_Host_Configuration_and_Guest_Installation_Guide/form-Virtualization_Host_Configuration_and_Guest_Installation_Guide-Para_virtualized_drivers-Mounting_the_image_with_virt_manager.html

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6-Beta/html/Virtualization_Host_Configuration_and_Guest_Installation_Guide/form-Virtualization_Host_Configuration_and_Guest_Installation_Guide-Para_virtualized_drivers-Installing_with_a_virtualized_floppy_disk.html

Thank you,
Dayle

*** This bug has been marked as a duplicate of bug 752738 ***

Note You need to log in before you can comment on or make changes to this bug.