Bug 815343 - [eap6] server configuration initialization should happen when importing, not when discovered
[eap6] server configuration initialization should happen when importing, not ...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
4.4
Unspecified Unspecified
high Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2012-04-23 08:27 EDT by Libor Zoubek
Modified: 2015-11-01 19:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 10:00:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2012-04-23 08:27:47 EDT
Description of problem: It is quite hard to describe, I'll describe my scenario:

1. I've setup EAP6 as unsecured, I've started it and got it discovered by agent. I've reproduced Bug 789292, so I've decided to secure my EAP. 
2. I've removed EAP from RHQ inventory
3. I've stopped EAP, secured it and started again
4. I've run autodiscovery on agent - for my server with new configuration to be discovered
5. I've imported it and reproduced Bug 789292 again!!

Why that happened? Right afer step 2, EAP was discovered and was still unsecured. Then when I've fixed it's configuration and imported it, RHQ was treating it still as unsecured. That means, there is something, that happens when discovery runs, some initializations.

I think this is a bug in as7 plugin, because it initializes some fields (like path to management realm which is in standalone.xml) during discovery time. 

Probably, in step 4, agent skipped "deeper" discovery of EAP, because it already knew about it

Version-Release number of selected component (if applicable):
Version: 4.4.0-SNAPSHOT
Build Number: 28e565c
EAP6 ER5

How reproducible:always


Expected results: agent should recognize server to be secured even without running step 4.


Additional info:
Comment 1 Heiko W. Rupp 2012-04-24 10:00:56 EDT
Plugin configuration is always initially populated at discovery time and not at import time. That is the way RHQ works.

You can force a re-initialization by changing some plugin configuration properties and save them.

Note You need to log in before you can comment on or make changes to this bug.