Bug 815351 - root crashes are not visible
root crashes are not visible
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 08:51 EDT by Kamil Páral
Modified: 2013-02-25 21:37 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 20:15:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-04-23 08:51:33 EDT
Description of problem:
If a program running under root crashes, abrt dialog doesn't pop up for a standard user (even when he has admin privileges). The only way to display and report the crash is to run abrt-gui under root account.

According to mtoman this should be already fix in abrt git using policykit, but it seems that F17 still doesn't contain fixed version.

Version-Release number of selected component (if applicable):
abrt-2.0.10-1.fc17.i686
abrt-addon-ccpp-2.0.10-1.fc17.i686
abrt-addon-kerneloops-2.0.10-1.fc17.i686
abrt-addon-python-2.0.10-1.fc17.i686
abrt-addon-vmcore-2.0.10-1.fc17.i686
abrt-dbus-2.0.10-1.fc17.i686
abrt-desktop-2.0.10-1.fc17.i686
abrt-gui-2.0.10-1.fc17.i686
abrt-libs-2.0.10-1.fc17.i686
abrt-retrace-client-2.0.10-1.fc17.i686

How reproducible:
always

Steps to Reproduce:
1. run gcalctool under root
2. kill it with SEGV or ABRT
3. see no notification for standard user
4. run abrt-gui as standard user, see nothing reported
4. run abrt-gui as root, see crash report
Comment 1 Kamil Páral 2012-04-23 08:53:08 EDT
Proposing as F17 NTH.
Comment 2 Kamil Páral 2012-04-23 09:24:01 EDT
OK, I'm lame, I didn't notice checkbox "Show all crashes", which shows root crashes even in standard user view. But I believe we still should pop up warnings for such crashes, otherwise the user might have no idea that something has crashed.
Comment 3 Kamil Páral 2012-04-27 04:35:30 EDT
I have talked to Jiri Moskovcak, ABRT developer, and he claimed that root crashes had never been announced by system notifications. But they intend to improve that for F17. Since this is not a regression, as I believed, I'm dropping the NTH proposal.
Comment 5 Fedora Update System 2012-12-20 03:54:14 EST
abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
Comment 6 Fedora Update System 2012-12-20 04:44:44 EST
abrt-2.0.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc17
Comment 7 Fedora Update System 2012-12-20 20:28:18 EST
Package abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.20-1.fc18 btparser-0.24-1.fc18 libreport-2.0.20-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20725/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-01-11 20:15:03 EST
abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-02-25 21:37:09 EST
abrt-2.0.20-1.fc17, btparser-0.24-1.fc17, libreport-2.0.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.