Bug 815353 - (PM-154, PRODMGT-154) RFE: expose GroupDefinitionManager remotely
RFE: expose GroupDefinitionManager remotely
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.1.0
Unspecified Unspecified
high Severity medium
: ER01
: JON 3.2.0
Assigned To: Jirka Kremser
Mike Foley
: FutureFeature
Depends On: 880819
Blocks: 966125
  Show dependency treegraph
 
Reported: 2012-04-23 08:56 EDT by Lukas Krejci
Modified: 2014-01-02 15:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 880819 966125 (view as bug list)
Environment:
Last Closed:
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker PRODMGT-154 Major Closed expose GroupDefinitionManager remotely 2014-01-14 10:55:09 EST
Red Hat Knowledge Base (Solution) 108883 None None None Never

  None (edit)
Description Lukas Krejci 2012-04-23 08:56:52 EDT
Description of problem:

We don't expose any methods to create, update or delete dyna-groups which prevents the CLI to automate working with them. This is a glaring omission, IMHO.

Version-Release number of selected component (if applicable):
4.4.0-SNAPSHOT
Comment 2 Charles Crouch 2012-05-08 11:43:51 EDT
Lukas
What is the level of effort here?
Comment 3 Lukas Krejci 2012-05-09 07:21:36 EDT
I believe the effort should not be significant - it should be a matter of choosing the methods from the local iface to be exposed in the remote interface, too, possibly slightly changing their signatures to be more "user friendly".

There is a support for criteria queries on group definitions so even our standard querying approach is already in place.
Comment 4 Charles Crouch 2012-05-15 18:33:11 EDT
Targeting for JON3.2
Comment 5 Jirka Kremser 2013-01-30 11:11:23 EST
master
http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=74dfd37db

time:    Wed Jan 30 17:08:46 2013 +0100
commit:  74dfd37db100de71128db47eb83962c686c8c925
author:  Jirka Kremser - jkremser@redhat.com
message: [Bug 880819 - RFE: expose GroupDefinitionManager remotely] Subset of methods defined in the local intercace has been exposed via the remote interaces and registered in the RhqManager.

Moving status to MODIFIED.
Comment 6 Jirka Kremser 2013-01-31 10:57:34 EST
master
http://git.fedorahosted.org/cgit/rhq/rhq.git/diff/?id=281605c82

281605c82 53 seconds ago Jirka Kremser [Bug 880819 - RFE: expose GroupDefinitionManager remotely] No need for exposing the "getById()" method. There is a common criteria finder available and other remote managers don't expose this getById() methods either. We should keep the api consistent.
Comment 7 Jirka Kremser 2013-02-08 10:09:00 EST
As discussed during today's hangout, bugs with 3.2.0 release should go to ON_QA, so I am moving it to ON_QA.
Comment 11 Mike Foley 2013-05-22 10:26:55 EDT
BZ for docuemtation/examples = https://bugzilla.redhat.com/show_bug.cgi?id=966125
Comment 15 Heiko W. Rupp 2013-08-08 09:52:31 EDT
This should be in a brew build since quite a while now.
Comment 16 Heiko W. Rupp 2013-09-06 10:57:31 EDT
Fixing target milestone
Comment 17 Mike Foley 2013-09-13 13:47:41 EDT
QE verified

https://engineering.redhat.com/trac/jon/ticket/584

Note You need to log in before you can comment on or make changes to this bug.