Bug 815358 - Implement CaseRun removal from a TestRun
Implement CaseRun removal from a TestRun
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-nitrate (Show other bugs)
rawhide
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Petr Šplíchal
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 09:09 EDT by Petr Šplíchal
Modified: 2016-05-31 21:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-nitrate-1.0-1.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 07:25:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2012-04-23 09:09:29 EDT
Description of problem:

Bug 726133 should be fixed soon so we will be able to remove case
runs from a test run. The caseruns should be implemented using the
Container class to allow both adding and removing test cases.

    TestRun(123).caseruns.add(TestCase(123))
    TestRun(123).caseruns.remove(TestCase(123))

Or, a new property testcases similar to that in TestPlan could be
added since iterating through test run test cases is also useful
and can be more handy than doing:

    if testcase in [caserun.testcase for caserun in testrun]

So the following could resolved this use case:

    TestRun(123).testcases.add(TestCase(123))
    TestRun(123).testcases.remove(TestCase(123))
Comment 1 Petr Šplíchal 2014-03-09 17:18:27 EDT
TestRun.caseruns and TestRun.testcases containers implemented

TestRun.caseruns reimplemented using RunCaseRuns container
TestRun.testcases container added for easier iteration
Supports adding/removing test cases to/from a test run

https://github.com/psss/python-nitrate/commit/32f1e675105c74d

Note You need to log in before you can comment on or make changes to this bug.