Bug 815365 - ami-cef922a7, ami-eaff2483: Entitlement missing
ami-cef922a7, ami-eaff2483: Entitlement missing
Status: CLOSED NOTABUG
Product: Cloud Image Validation
Classification: Red Hat
Component: images (Show other bugs)
RHEL6.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: mkovacik
mkovacik
: EC2
: 818132 818147 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 09:32 EDT by mkovacik
Modified: 2012-06-13 07:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 07:46:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screen log (15.84 KB, application/octet-stream)
2012-04-24 06:36 EDT, mkovacik
no flags Details

  None (edit)
Description mkovacik 2012-04-23 09:32:51 EDT
Description of problem:
Entitlement missing in ami-cef922a7 and ami-eaff2483.

Version-Release number of selected component (if applicable):
ami-cef922a7, ami-eaff2483

How reproducible:
N/A

Steps to Reproduce:
N/A
  
Actual results:
Unable to access CDN

Expected results:
CDN accessible

Additional info:
### Example Screen log
######################################################################################
# NEW TEST: ## List the configured repositories...
######################################################################################
COMMAND:  /usr/bin/yum repolist
Unable to read consumer identity
Repo rhui-us-east-1-rhel-server-releases-beta forced skip_if_unavailable=True
due to: /etc/pki/entitlement/content-rhel6-beta-key.pem
Repo rhui-us-east-1-rhel-server-releases-optional-beta forced
skip_if_unavailable=True due to:
/etc/pki/entitlement/content-rhel6-beta-key.pem
Repo rhui-us-east-1-rhel-server-releases forced skip_if_unavailable=True due
to: /etc/pki/entitlement/content-rhel6-key.pem
Repo rhui-us-east-1-rhel-server-releases-optional forced
skip_if_unavailable=True due to: /etc/pki/entitlement/content-rhel6-key.pem
RESULT: Loaded plugins: amazon-id, product-id, rhui-lb, security,
subscription-manager
Updating certificate-based repositories.
Could not retrieve mirrorlist
https://rhui2-cds01.us-east-1.aws.ce.redhat.com/pulp/mirror/content/dist/rhel/rhui/server/6/6Server/i386/os
error was
14: problem with the local client certificate
Could not retrieve mirrorlist
https://rhui2-cds01.us-east-1.aws.ce.redhat.com/pulp/mirror/content/beta/rhel/rhui/server/6/6Server/i386/os
error was
14: problem with the local client certificate
Could not retrieve mirrorlist
https://rhui2-cds01.us-east-1.aws.ce.redhat.com/pulp/mirror/content/dist/rhel/rhui/server/6/6Server/i386/optional/os
error was
14: problem with the local client certificate
Could not retrieve mirrorlist
https://rhui2-cds01.us-east-1.aws.ce.redhat.com/pulp/mirror/content/beta/rhel/rhui/server/6/6Server/i386/optional/os
error was
14: problem with the local client certificate
repo id                                    repo name                     
status
Comment 2 mkovacik 2012-04-24 06:36:45 EDT
Created attachment 579818 [details]
Screen log

Even though the yum commands work now, some issues still remain:
### from the screen log
  Could not retrieve mirrorlist https://rhui2-cds01.us-east-1.aws.ce.redhat.com/pulp/mirror/content/beta/rhel/rhui/server/6/6Server/x86_64/os error was
  14: problem with the local client certificate
Comment 3 Kevin Wright 2012-04-30 17:47:46 EDT
I've uploaded new images with a fix for this:

relengo candidate list |grep 6.3 |grep pending
Beta         | x86_64 | us-east-1       | access  | 6.3     | EBS Image            | ??      | ami-347ca65d | pending
Beta         | i386   | us-east-1       | access  | 6.3     | EBS Image            | ??      | ami-567ca63f | pending

these include a new build of of rh-amazon-rhui-client from here:

https://brewweb.devel.redhat.com/buildinfo?buildID=210624
Comment 4 Kevin Wright 2012-04-30 22:35:10 EDT
Note. These are based on the same Beta-1.1 raw files with only a change to the rh-amazon-rhui-client.
Comment 5 mkovacik 2012-05-02 06:42:57 EDT
Still not working correctly:

### ami-567ca63f
[root@ip-10-76-178-41 src]# yum repolist
Loaded plugins: amazon-id, product-id, rhui-lb, security, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
Repo rhui-us-east-1-rhel-server-releases-beta forced skip_if_unavailable=True due to: /etc/pki/entitlement/content-rhel6-beta-key.pem
Repo rhui-us-east-1-rhel-server-releases-optional-beta forced skip_if_unavailable=True due to: /etc/pki/entitlement/content-rhel6-beta-key.pem
rhui-us-east-1-client-config-server-6                                                                                                                                                                                                               | 2.6 kB     00:00     
rhui-us-east-1-client-config-server-6-beta                                                                                                                                                                                                          | 2.6 kB     00:00     
rhui-us-east-1-rhel-server-releases                                                                                                                                                                                                                 | 3.7 kB     00:00     
Could not retrieve mirrorlist https://rhui2-cds01.us-east-1.aws.ce.redhat.com/pulp/mirror/content/beta/rhel/rhui/server/6/6Server/i386/os error was
14: problem with the local client certificate
rhui-us-east-1-rhel-server-releases-optional                                                                                                                                                                                                        | 3.5 kB     00:00     
Could not retrieve mirrorlist https://rhui2-cds01.us-east-1.aws.ce.redhat.com/pulp/mirror/content/beta/rhel/rhui/server/6/6Server/i386/optional/os error was
14: problem with the local client certificate
repo id                                                                                                                  repo name                                                                                                                                   status
rhui-us-east-1-client-config-server-6                                                                                    Red Hat Update Infrastructure 2.0 Client Configuration Server 6                                                                                 1
rhui-us-east-1-client-config-server-6-beta                                                                               Red Hat Update Infrastructure 2.0 Client Configuration Server 6                                                                                 0
rhui-us-east-1-rhel-server-releases                                                                                      Red Hat Enterprise Linux Server 6 (RPMs)                                                                                                    5,439
rhui-us-east-1-rhel-server-releases-optional                                                                             Red Hat Enterprise Linux Server 6 Optional (RPMs)                                                                                           3,157
repolist: 8,597
[root@ip-10-76-178-41 src]# rpm -q rh-amazon-rhui-client
rh-amazon-rhui-client-2.2.49-1.el6_2.noarch
[root@ip-10-76-178-41 src]# rpm -qi rh-amazon-rhui-client
Name        : rh-amazon-rhui-client        Relocations: (not relocatable)
Version     : 2.2.49                            Vendor: Red Hat, Inc.
Release     : 1.el6_2                       Build Date: Mon 23 Apr 2012 02:04:49 PM EDT
Install Date: Mon 30 Apr 2012 03:51:17 PM EDT      Build Host: s390-001.build.bos.redhat.com
Group       : System Environment/Base       Source RPM: rh-amazon-rhui-client-2.2.49-1.el6_2.src.rpm
Size        : 41189                            License: BSD
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://redhat.com
Summary     : Yum repository and entitlement certificate configuration
Description :
Configures yum to use the RHUI repositories.
Comment 6 mkovacik 2012-05-02 06:59:39 EDT
*** Bug 818132 has been marked as a duplicate of this bug. ***
Comment 7 mkovacik 2012-05-02 07:14:36 EDT
*** Bug 818147 has been marked as a duplicate of this bug. ***
Comment 8 James Slagle 2012-05-03 10:18:08 EDT
Looks like the ami rebuild only picked up the new version of rh-amazon-rhui-client.  You need the new version of rh-amazon-rhui-client-beta as well.


From ami-567ca63f:

[root@ip-10-2-114-143 ~]# rpm -q rh-amazon-rhui-client rh-amazon-rhui-client-beta
rh-amazon-rhui-client-2.2.49-1.el6_2.noarch
rh-amazon-rhui-client-beta-2.2.42-1.el6.noarch
Comment 9 Kevin Wright 2012-05-07 16:32:34 EDT
I've gone ahead and re-uploaded the us-east-1 images of rhel-6.3 beta with rh-amazon-rhui-client-beta-2.2.42-1.el6.noarch:

ami-347ca65d x86_64
ami-567ca63f i386
Comment 10 mkovacik 2012-05-11 08:52:10 EDT
Verified in: ami-60b01509, ami-5ab01533
(https://bugzilla.redhat.com/show_bug.cgi?id=820549 https://bugzilla.redhat.com/show_bug.cgi?id=820558)
Comment 11 mkovacik 2012-06-13 07:43:23 EDT
Closing validated amis.
Comment 12 mkovacik 2012-06-13 07:46:03 EDT
Closing validated amis.

Note You need to log in before you can comment on or make changes to this bug.