Bug 81537 - executil.py:216:gtkExecWithCaptureStatus:TypeError: len() of unsized object
executil.py:216:gtkExecWithCaptureStatus:TypeError: len() of unsized object
Status: CLOSED DUPLICATE of bug 80355
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-09 23:40 EST by Pam Huntley
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pam Huntley 2003-01-09 23:40:09 EST
Description of problem:
redhat-config-network crashes when I try to activate eth0.  It didn't come up
automatically after I installed, so I went to the utility and clicked on add,
and it had the ethernet card (intel etherexpress 1000) listed as an option, so I
clicked on that and set it up as dhcp.  When I went to activate it, it said to
save, so I saved, and then it crashed with the activating interface progress
dialog still up.  then I went to activate eth0 from the command line and it
worked, and deactivating eth0 worked, but whenever I went to activate, it crashed.

Version-Release number of selected component (if applicable):


How reproducible:
always.

Steps to Reproduce:
1.  install pheobe
2.  run config
3.  set up eth0 as dhcp
4.  activate interface
5.  it prompts to save, then crashes.
    
Actual results:
crash

Expected results:
activate interface

Additional info:
lspci for ethernet card:
02:01.0 Ethernet controller: Intel Corp.: Unknown device 101e (rev 03)

Error message from crash:
Component: redhat-config-network
Version: 1.1.86
Summary: TB
/usr/lib/python2.2/site-packages/rhpl/executil.py:216:gtkExecWithCaptureStatus:
TypeError: len() of unsized object
                                                                                 
Traceback (most recent call last):
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 734, in on_deviceActivateButton_clicked
    (status, txt) = intf.activate(device)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
107, in activate
    return gtkExecWithCaptureStatus(command, [command, device])
  File "/usr/lib/python2.2/site-packages/rhpl/executil.py", line 216, in
gtkExecWithCaptureStatus
    if len(catchfd):
TypeError: len() of unsized object
                                                                                 
Local variables in innermost frame:
gtk: <module 'gtk' from '/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.pyc'>
catchfd: 1
searchPath: 0
read: 13
stdin: 0
argv: ['/sbin/ifup', 'eth0']
write: 14
command: /sbin/ifup
closefd: -1
root: /
childpid: 0
Comment 1 Harald Hoyer 2003-01-13 06:05:37 EST

*** This bug has been marked as a duplicate of 80355 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:51:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.