Bug 815376 - pyfits depends on python3 (which should be true only for python3-pyfits)
Summary: pyfits depends on python3 (which should be true only for python3-pyfits)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pyfits
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sergio Pascual
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-23 13:51 UTC by Michal Szymanski
Modified: 2012-07-05 23:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-05 23:31:11 UTC


Attachments (Terms of Use)

Description Michal Szymanski 2012-04-23 13:51:16 UTC
Description of problem: As with many other python modules, there are two pyfits rpms available, "pyfits" and "python3-pyfits". Unfortunately, installing 'pyfits' requires python3 to be also installed which IMHO is not proper. Python modules packages not starting with python3- in their names, should be intented for the default python 2.7 coming with F16

Version-Release number of selected component (if applicable): 3.0.1-1


How reproducible: always


Steps to Reproduce:
1. yum install pyfits
  
Actual results:
Installing:
 pyfits               x86_64        3.0.1-1.fc16           updates        440 k
Installing for dependencies:
 python3              x86_64        3.2.1-1.fc16           fedora          33 k
 python3-libs         x86_64        3.2.1-1.fc16           fedora         5.3 M
 python3-numpy        x86_64        1:1.6.1-2.fc16         updates        2.9 M

Expected results:
No dependencies on python3

Additional info:

Comment 1 Sergio Pascual 2012-04-24 11:00:13 UTC
The dependency comes from the fitscheck program. A fix will arrive soon

Comment 2 Fedora Update System 2012-07-03 13:46:48 UTC
pyfits-3.0.8-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-9938/pyfits-3.0.8-1.fc16

Comment 3 Fedora Update System 2012-07-05 23:31:11 UTC
pyfits-3.0.8-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.