Bug 815383 - Forge: Invalid Application Type Specified
Forge: Invalid Application Type Specified
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 10:02 EDT by Attila Nagy
Modified: 2015-05-14 21:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 09:28:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Nagy 2012-04-23 10:02:13 EDT
Description of problem: Setting up an OpenShift application in JBoss Forge will produce the following error.

$ forge install-plugin openshift-express
Connecting to remote repository [https://raw.github.com/forge/plugin-repository/master/repository.yaml]... connected!
***INFO*** Preparing to install plugin: openshift-express
***INFO*** Checking out plugin source files to [/tmp/forgetemp7707813405826379063/repo] via 'git'
***INFO*** Switching to branch/tag [refs/tags/1.0.0.Beta5]
***INFO*** Invoking build with underlying build system.
[INFO] Scanning for projects...
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building openshift-express-plugin 1.0.2-SNAPSHOT
[INFO] ------------------------------------------------------

<....>

[no project] attila $ new-project --named forge-openshift-demo --topLevelPackage org.jboss.forge.openshift
 ? Use [/home/attila/forge-openshift-demo] as project directory? [Y/n] y
***SUCCESS*** Created project [forge-openshift-demo] in new working directory [/home/attila/forge-openshift-demo]
Wrote /home/attila/forge-openshift-demo
Wrote /home/attila/forge-openshift-demo/pom.xml
Wrote /home/attila/forge-openshift-demo/src/main/java
Wrote /home/attila/forge-openshift-demo/src/test/java
Wrote /home/attila/forge-openshift-demo/src/main/resources
Wrote /home/attila/forge-openshift-demo/src/test/resources
Wrote /home/attila/forge-openshift-demo/src/main/java/org/jboss/forge/openshift
Wrote /home/attila/forge-openshift-demo/src/main/resources/META-INF/forge.xml
[forge-openshift-demo] forge-openshift-demo $ rhc-express setup --app forge --rhlogin "anagy+2012042301@redhat.com"
***INFO*** Loaded OpenShift configuration from /home/attila/.openshift/express.conf
 ? Enter your Red Hat Login password ******
***ERROR*** OpenShift failed to create the application
***ERROR*** Could not configure application "forge" at "https://ec2-50-16-61-165.compute-1.amazonaws.com/broker/cartridge"
***ERROR*** {"debug":"","exit_code":1,"broker_c":["namespace","rhlogin","ssh","app_uuid","debug","alter","cartridge","cart_type","action","app_name","api"],"result":"Invalid application type (-t|--type) specified: 'jbossas-7.0'.  Valid application types are (nodejs-0.6, jbossas-7, python-2.6, jenkins-1.4, ruby-1.8, diy-0.1, php-5.3, perl-5.10).","data":"","api":"1.1.3","messages":"","api_c":["placeholder"]}
***ERROR*** [rhc-express setup] Could not complete installation of facet: [forge.openshift.express]. Installation was aborted by the Facet during installation.



Version-Release number of selected component (if applicable): 
forge-distribution-1.0.3-20120421.161231-20.zip
ami-905d86f9


How reproducible: Always


Steps to Reproduce: 
1. Install Forge; Use the step-by-step instructions on the following web-site
https://docs.jboss.org/author/display/FORGE/Installation
2. Install openshift plugin: forge install-plugin openshift-express
3. Create a new forge project: new-project --named forge-openshift-demo --topLevelPackage org.jboss.forge.openshift
4. rhc-express setup --app forge --rhlogin "anagy+2012042301@redhat.com"

  
Actual results: Error-message about invalid application type


Expected results: Application in openshift must be created successfully


Additional info: The user in OpenShift has a domain name already created
Comment 1 Attila Nagy 2012-04-24 09:28:33 EDT
I could not reproduce this bug today.
Closing...

Note You need to log in before you can comment on or make changes to this bug.