Bug 815433 - sam-rhel-x86_64-server-6-beta channel mapping needs replacement in channel-cert-mapping.txt
sam-rhel-x86_64-server-6-beta channel mapping needs replacement in channel-ce...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-04-23 11:30 EDT by John Sefler
Modified: 2012-06-20 09:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:37:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-04-23 11:30:56 EDT
Description of problem:

In the master product-baseline definition, new channels for sam-rhel-x86_64-server-6 and sam-rhel-x86_64-server-6-debug-info are
now mapped to the Red Hat Enterprise Linux Server product ID 69.  As such, the
channel-cert-mapping.txt file should also have these mappings, but currently
does not.  The BETA sam-rhel-x86_64-server-6-beta and sam-rhel-x86_64-server-6-beta-debuginfo should be replaced.

Cut from http://git.app.eng.bos.redhat.com/?p=rcm/rhn-definitions.git;a=blob;f=cdn/product-baseline.json;hb=HEAD

         "Name": "Red Hat Enterprise Linux Server", 
         "Product ID": "69", 
         "RHN Channels": [
             <...CUT OUT MANY CHANNELS FOR BREVITY...>
             "sam-rhel-x86_64-server-6", 
             "sam-rhel-x86_64-server-6-debuginfo"
         ]


Version-Release number of selected component (if applicable):
[root@jsefler-r63-server ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.1.3-1.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-r63-server ~]# grep sam-rhel-x86_64-server-6 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
sam-rhel-x86_64-server-6-beta: Server-Server-x86_64-23d36f276d57-69.pem
sam-rhel-x86_64-server-6-beta-debuginfo: Server-Server-x86_64-23d36f276d57-69.pem

  
^^^
Expected those two mapping hits to now be non-beta hits:
sam-rhel-x86_64-server-6: Server-Server-x86_64-23d36f276d57-69.pem
sam-rhel-x86_64-server-6-debuginfo: Server-Server-x86_64-23d36f276d57-69.pem
Comment 1 Alex Wood 2012-04-23 15:00:54 EDT
Committed 2a44ddb026d95f52fd9e381971ddf4e1e37e1c81 in RHEL6 branch
Committed 30ec146f2176756418fe3fbe29a7bc31e767b84d in RHEL6.3 branch
Comment 3 John Sefler 2012-04-25 18:44:03 EDT
Verifying version...
[root@jsefler-r63-server ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.1.5-1.el6.noarch

[root@jsefler-r63-server ~]# grep sam-rhel-x86_64-server-6 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
sam-rhel-x86_64-server-6: Server-Server-x86_64-23d36f276d57-69.pem
sam-rhel-x86_64-server-6-debuginfo: Server-Server-x86_64-23d36f276d57-69.pem
[root@jsefler-r63-server ~]# 


VERIFIED: The sam-rhel beta channel mappings have been replaced by the non-beta channels.
Comment 5 errata-xmlrpc 2012-06-20 09:37:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0823.html

Note You need to log in before you can comment on or make changes to this bug.