Bug 815469 - Floppy driver cause kernel panic in slow virtualized environment
Floppy driver cause kernel panic in slow virtualized environment
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 815472
  Show dependency treegraph
 
Reported: 2012-04-23 12:30 EDT by Pavel Hrdina
Modified: 2012-08-10 15:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 815472 (view as bug list)
Environment:
Last Closed: 2012-08-10 15:39:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace-rhel6 (3.89 KB, text/plain)
2012-04-23 15:49 EDT, Pavel Hrdina
no flags Details
backtrace-fedora16 (7.35 KB, text/plain)
2012-04-23 16:02 EDT, Pavel Hrdina
no flags Details

  None (edit)
Description Pavel Hrdina 2012-04-23 12:30:46 EDT
Description of problem:
Floppy driver cause kernel panic in slow virtualized environment.

Version-Release number of selected component (if applicable):
all

How reproducible:
75%

Steps to Reproduce:
1. run qemu without kvm support and with floppy image inserted
2. in guest run "modprobe floppy" and then "mount /dev/fd0 /mnt"
3. mount command cause kernel panic, but not always
  
Actual results:
kenrel panic

Expected results:
mount floppy without kernel panic
Comment 1 Josh Boyer 2012-04-23 12:34:59 EDT
Can you attached the backtrace?  Also, which kernel version(s)?
Comment 2 Pavel Hrdina 2012-04-23 15:49:55 EDT
Created attachment 579675 [details]
backtrace-rhel6

Here is the backtrace on rhel6.3 you asked for and kernel version is 2.6.32-262.el6.x86_64
Comment 3 Josh Boyer 2012-04-23 16:00:34 EDT
(In reply to comment #2)
> Created attachment 579675 [details]
> backtrace
> 
> Here is the backtrace on rhel6.3 you asked for and kernel version is
> 2.6.32-262.el6.x86_64

You reported this against Fedora rawhide.  Does it happen there, or is this a RHEL-only bug?  If it happens in Fedora, can you attach the Fedora kernel backtrace?
Comment 4 Pavel Hrdina 2012-04-23 16:02:27 EDT
Created attachment 579681 [details]
backtrace-fedora16

Here is the backtrace on fedora16 and kernel version is 3.3.0-8.fc16.x86_64
Comment 5 Josh Boyer 2012-08-10 15:39:29 EDT
I tried this with the latest rawhide kernel on a non-KVM guest.  I ran:

modprobe floppy; mount /dev/fd0 /mnt; umount /mnt; modprobe -r floppy

several times and never got an oops.  There have been a number of block and floppy related changes since 3.3.

I'm going to close this bug out as fixed.  If you can recreate with the latest rawhide kernel, please reopen.

I do, however, question how much we care about this specific use case.  AFAIK, RHEL doesn't support non-KVM qemu and while Fedora might, it's use is rather limited particularly with floppy images.

Note You need to log in before you can comment on or make changes to this bug.