This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 815474 - Preugprade from F16 to F17 Beta does not appear to regenerate initrd successfully
Preugprade from F16 to F17 Beta does not appear to regenerate initrd successf...
Status: CLOSED DUPLICATE of bug 820351
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 12:47 EDT by Eike Hein
Modified: 2012-05-09 14:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-09 14:18:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eike Hein 2012-04-23 12:47:51 EDT
After I ran preupgrade on F16 with updates-testing enabled, rebooted, let Anaconda perform the upgrade and reboot again, I was greeted by a splash screen still identifying the release as Fedora 16 (I use the nVidia binary drivers via rpmfusion, so I get a textmode boot splash rather than plymouth which iirc doesn't show the release version).

Once booted into the upgraded system, I ran yum upgrade to fetch further updated packages. Then, when I tried to reboot, the system failed to shut down successfully, halting during the process with a bunch of path errors. IIRC being unable to find /shutdown and /reboot were among them, and there may have been more.

I then performed a hardware reset and let the system boot back up again. It now identifies itself as Fedora 17 and reboots normally.

My conclusion/understanding is that during the upgrade, the initrd was not properly regenerated. Or perhaps there was some other kind of brokeness in the initial upgraded packages prior to another yum upgrade -- please feel free to rename the bug if I'm completely wrong here.
Comment 1 Adam Williamson 2012-05-09 14:03:18 EDT
So, Eike thinks he got an fc17 kernel, but that's not what it sounds like to me. I've just verified a couple of things...

1) It's quite easy to do a 16->17 upgrade and not get a 17 kernel, because the 16 kernel is being kept very up to date; it's been the case quite a few times that the latest 16 kernel is 'newer' than the latest 17 kernel.

2) If you boot 17 with a kernel that was installed when the system was running 16, you will not be able to shut down properly, because the initramfs is pre-/usrmove. So booting a 16 kernel on 17 is problematic.

I think this is the case Eike ran into. I'm filing a bug against anaconda to highlight this little problem and see if anything can be done to improve the situation. I'll close this as a dupe when it's done.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Eike Hein 2012-05-09 14:11:05 EDT
Aye, I'm fairly certain the boot menu string referenced F17 because I was paying special attention due to bug 815473, but I can't speak to whether the kernel line pointed to the right file. Since we can't seem to come up with another explanation for the symptoms I'm on board with your plans, though.
Comment 3 Adam Williamson 2012-05-09 14:18:27 EDT
it may have just said 'Fedora Linux'. that's what shiny new grub2 does, that's what I see on my 'updated 16 -> 17 Beta DVD' upgrade test. but if you look at it in more detail, what it boots is an fc16 kernel.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 820351 ***

Note You need to log in before you can comment on or make changes to this bug.