Bug 815483 - extras/init.d/glusterd-Redhat stop action kills glusterfsd?
extras/init.d/glusterd-Redhat stop action kills glusterfsd?
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
mainline
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Amar Tumballi
Ujjwala
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-04-23 13:11 EDT by Louis Zuckerman
Modified: 2013-12-18 19:08 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:20:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Louis Zuckerman 2012-04-23 13:11:10 EDT
Description of problem:
There are three initscripts in extras/init.d, debian, suse, and redhat.  of these, the debian & suse scripts "stop" action only stops the glusterd process, and does not touch running glusterfsd processes.  the redhat script (line 52-53), on the other hand, appears to stop both glusterd & glusterfsd processes.  Is that  right?

Version-Release number of selected component (if applicable):

All?

How reproducible:

Personally, I can only confirm the behavior on debian-derived distros (debian & ubuntu) and it is true that "service glusterd stop" does not kill running glusterfsd processes.

I do not have access to a redhat or suse box to test.

Steps to Reproduce:
1. Create volume
2. Start volume
3. "service glusterd stop"
4. did the glusterfsd process get killed also?
  
Actual results:

On debian/ubuntu only the glusterd process is killed, glusterfsd processes are left alone.

On Redhat?

On Suse?

Expected results:

The expected behavior is that only the glusterd process will be killed by "service glusterd stop", but glusterfsd processes will be left alone.


Additional info:

IMHO there needs to be consensus & consistency across distributions as to what "service glusterd stop" will accomplish.  I think it should only stop glusterd, and leave running glusterfsd processes alone, because those are controlled pool-wide using "gluster volume start/stop" commands.

Thank you!
Comment 1 Amar Tumballi 2012-04-23 22:15:49 EDT
patch @ http://review.gluster.com/2919 fixes the issue. This will go in after a review.
Comment 2 Amar Tumballi 2012-05-19 02:42:19 EDT
Patch committed in upstream.
Comment 3 Anush Shetty 2012-05-31 03:02:56 EDT
Verified in master (f2a3291c2fe5a00bca1e4a77a37560ec30cc24bf)

Note You need to log in before you can comment on or make changes to this bug.