Bug 815510 - (INC000000528680) Package search results in Proxy Error for some users
Package search results in Proxy Error for some users
Status: CLOSED DEFERRED
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
AMS Backlog
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: rhn-dev-list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 14:27 EDT by Brooks
Modified: 2012-11-12 16:48 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 11:12:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brooks 2012-04-23 14:27:29 EDT
Description of problem:
Appears that only for some accounts with large amount of systems registered (needs to be confirmed), a Proxy error will occur if the switch under the sub-section, 'where to search:' is specified as 'Channels relevant to your systems'. I cannot reproduce this issue if the switch 'Channels relevant to your systems' is not selected, and a architecture is specified in the search.

It does not matter what the search criteria is as long as the switch 'Channels relevant to your systems' is selected. I was able to reproduce this using 'asfd' and also logical search terms like, 'virtio-win' when the channels relevant to your system switch is set to true.

How reproducible:
Every time

Steps to Reproduce:
***Use C-service to become either rhn-support-rfreire OR rhn-support-akaiser
1. Go to https://rhn.redhat.com/rhn/channels/software/Search.do
2. Type into search, 'virtio-win' and make sure 'channels relevant to your systems' is selected
3. Select 'Search'
  
Actual results:
A 502 Proxy error will appear

Expected results:
The search performs as expected, and will display systems that search criteria applies to OR will show no packages if none of the search criteria applies to the systems within the ORG. 

Additional info:
This was reported in Remedy ticket INC000000528680
Comment 2 Brooks 2012-09-26 10:38:24 EDT
US19499
Comment 3 vikas kumar 2012-10-30 11:12:52 EDT
According to RHN BA (Nicky) :- 

Per Mike, we do not want to fix this bug.  There are other plans for search at this time that Mike will be addressing.  

So, I will go ahead and close this bug. Thanks.
Comment 4 Jan Pazdziora 2012-10-30 12:45:42 EDT
Shouldn't this be WONTFIX then, rather than NOTABUG. The bug is still there alright.
Comment 5 Brooks 2012-11-12 16:48:14 EST
For all those whom have watched this bug (and maybe more importantly for those who were upset this bug was closed), you can now follow, 'Bug 872746 - Cleaning technical debt by enabling search (GSA) to crawl packages and errata'.

This is what will replace the package search mentioned in this bug, Bug 815510

Note You need to log in before you can comment on or make changes to this bug.