Bug 815563 - System preferences dialog needs new at-spi locators
System preferences dialog needs new at-spi locators
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
J.C. Molet
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-04-23 17:09 EDT by J.C. Molet
Modified: 2012-06-20 08:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:56:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system prefs (832.54 KB, image/png)
2012-04-26 10:34 EDT, J.C. Molet
no flags Details

  None (edit)
Description J.C. Molet 2012-04-23 17:09:34 EDT
Description of problem:
It looks like the glade file for the System Preferences dialog in subscription-manager-gui has been copied directly from the register dialog and modified for special use.  Normally that's cool, but it seems that none of the at-spi locators were changed, so everything still says "register_dialog" instead of "system-preferences", so it is very confusing.


Version-Release number of selected component (if applicable):
subscription-manager-gnome-1.0.0-1.git.32.1d1ef82.el6_2.x86_64

How reproducible:
always

Steps to Reproduce:
1. Open the system preferences dialog and then look at the locators through your favorite at-spi broswer (like sniff from the dogtail package).
  
Actual results:
in the file: 
subscription-manager/src/subscription_manager/gui/data/preferences.glade

you have the following lines for

The window title:  
<atkproperty name="AtkObject::accessible-name">register_dialog</atkproperty>

The vbox containing the elements:
<atkproperty name="AtkObject::accessible-name" translatable="yes">register_dialog_main_vbox</atkproperty>

The action area:
<atkproperty name="AtkObject::accessible-name" translatable="yes">registration_dialog_action_area
</atkproperty>

The close button:
<atkproperty name="AtkObject::accessible-name" translatable="yes">register_button</atkproperty>
<atkproperty name="AtkObject::accessible-description">register_button</atkproperty>

Expected results:

All of the <accessibility> </accessibility> sections could be removed; window titles and button objects are automatically given an at-spi locator of the same name.  Additionally the vbox and action-area only serve as organizational divisions and are not usable or clickable - therefore don't really NEED a locator either though they could be simply renamed.

Additional info:
Comment 1 Alex Wood 2012-04-24 10:33:09 EDT
commit 39ce1eacf41671011eadd357648d3e5db890d87b
Author: Alex Wood <awood@redhat.com>
Date:   Tue Apr 24 10:26:36 2012 -0400

    815563: Remove incorrect at-spi locators.
Comment 2 Alex Wood 2012-04-24 10:49:22 EDT
Committed 51da3ce32a059800a66bbb83935df593337998d0 to RHEL6.3
Comment 6 J.C. Molet 2012-04-26 10:34:44 EDT
Created attachment 580499 [details]
system prefs

subscription-manager-gnome-1.0.0-1.git.39.fc7bf19.el6_2.x86_64


Fixed in the above version.

All things are named properly and all traces of register_dialog have been removed from this window.
Comment 8 errata-xmlrpc 2012-06-20 08:56:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.