Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 815598 - [RFE] virt.uuid should not be "Unknown" in s390x when list facts
Summary: [RFE] virt.uuid should not be "Unknown" in s390x when list facts
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.3
Hardware: s390x
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: Entitlement Bugs
URL:
Whiteboard:
Depends On:
Blocks: 738066
TreeView+ depends on / blocked
 
Reported: 2012-04-24 02:56 UTC by xhe@redhat.com
Modified: 2017-12-06 12:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 12:19:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description xhe@redhat.com 2012-04-24 02:56:45 UTC
Description of problem:
virt.uuid should not be "Unknown" in s390x when list facts

Version-Release number of selected component (if applicable):
subscription-manager-0.99.14-1.el6.s390x
python-rhsm-0.99.8-1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.subscription-manager facts --list

Actual results:
here is the result of step1:
*******************************************************
[root@ibm-z10-32 ~]# subscription-manager facts --list
cpu.core(s)_per_socket: 2
cpu.cpu(s): 2
cpu.cpu_socket(s): 1
distribution.id: Santiago
distribution.name: Red Hat Enterprise Linux Server
distribution.version: 6.3
lscpu.architecture: s390x
lscpu.byte_order: Big Endian
lscpu.core(s)_per_socket: 1
lscpu.cpu(s): 2
lscpu.cpu_op-mode(s): 32-bit, 64-bit
lscpu.cpu_socket(s): 2
lscpu.on-line_cpu(s)_list: 0,1
lscpu.thread(s)_per_core: 1
lscpu.vendor_id: IBM/S390
memory.memtotal: 887880
memory.swaptotal: 1032184
net.interface.eth0.ipv4_address: 10.16.66.223
net.interface.eth0.ipv4_broadcast: 10.16.71.255
net.interface.eth0.ipv4_netmask: 21
net.interface.eth0.ipv6_address.global: 2620:52:0:1040:de:adff:febe:ef20
net.interface.eth0.ipv6_address.link: fe80::de:adff:febe:ef20
net.interface.eth0.ipv6_address.site: fec0:0:a10:4000:de:adff:febe:ef20
net.interface.eth0.ipv6_netmask.global: 64
net.interface.eth0.ipv6_netmask.link: 64
net.interface.eth0.ipv6_netmask.site: 64
net.interface.eth0.mac_address: 02:DE:AD:BE:EF:20
net.interface.lo.ipv4_address: 127.0.0.1
net.interface.lo.ipv4_broadcast: Unknown
net.interface.lo.ipv4_netmask: 8
net.interface.lo.ipv6_address.host: ::1
net.interface.lo.ipv6_netmask.host: 128
net.interface.lo.mac_address: 00:00:00:00:00:00
network.hostname: ibm-z10-32.rhts.eng.bos.redhat.com
network.ipv4_address: 10.16.66.223
network.ipv6_address: ::1
system.entitlements_valid: valid
system.name: ibm-z10-32.rhts.eng.bos.redhat.com
system.uuid: 1957657b-923f-4382-80c3-8ca23f4d46c7
uname.machine: s390x
uname.nodename: ibm-z10-32.rhts.eng.bos.redhat.com
uname.release: 2.6.32-262.el6.s390x
uname.sysname: Linux
uname.version: #1 SMP Sun Apr 8 18:51:19 EDT 2012
virt.host_type: ibm_systemz
ibm_systemz-zvm
virt.is_guest: True
virt.uuid: Unknown
*******************************************************
issue: virt.uuid should not be "Unknown" in s390x when list facts

Expected results:
virt.uuid should be a real uuid value instead of "Unknown"

Additional info:

Comment 1 Chris Duryee 2012-04-25 15:09:31 UTC
If virt.host_type is ibm_systemz, we explicitly mark the uuid as unknown. System Z VMs are not tracked via virt-who, so there is no need to track the virt.uuid.

Marking as closed/notabug, feel free to re-open the bz though if you have any questions or concerns.

Comment 2 John Sefler 2016-03-01 18:09:46 UTC
I agree that System Z VMs are not tracked via virt-who, but that's because we don't know how to do it yet.  The first step to figuring that out will be to determine the virt-uuid for this ibm_systemz-zvm.  Hence I am re-opening this bug as an RFE on s390x.


With the latest packages...
[root@ibm-z10-52 ~]# hostname
ibm-z10-52.rhts.eng.bos.redhat.com
[root@ibm-z10-52 ~]# rpm -q subscription-manager virt-what
subscription-manager-1.16.8-3.el6.s390x
virt-what-1.11-1.2.el6.s390x
[root@ibm-z10-52 ~]# 
[root@ibm-z10-52 ~]# virt-what
ibm_systemz
ibm_systemz-zvm
[root@ibm-z10-52 ~]# 
[root@ibm-z10-52 ~]# subscription-manager facts --list | grep virt
lscpu.virtualization_type: full
virt.host_type: ibm_systemz, ibm_systemz-zvm
virt.is_guest: True
[root@ibm-z10-52 ~]# 

ISSUE: Since virt-what is indeed reporting this as a virtual guest, the subscription-manager facts should include a virt.uuid  Exactly how to determine the value of the virt.uuid is unknown.  For this we NEEDINFO.

Comment 4 Jan Kurik 2017-12-06 12:19:44 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.