Bug 815603 - "gluster vol geo-rep status" is broken
"gluster vol geo-rep status" is broken
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-04-23 23:11 EDT by Csaba Henk
Modified: 2013-07-24 13:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:28:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Csaba Henk 2012-04-23 23:11:34 EDT
Description of problem:

The cli command "gluster vol geo-rep status" should give info about all geo-rep sessions (outputting an empty table if there is none. It fails indeed.

Version-Release number of selected component (if applicable):


How reproducible:

Always.

Steps to Reproduce:
1. gluster vol geo-rep status

Actual results:

geo-replication command failed

Expected results:

MASTER               SLAVE                                              STATUS    
--------------------------------------------------------------------------------
...

Additional info:

- Similarly to Bug 812801, it's also caused by http://review.gluster.com/3083
- However, http://review.gluster.com/3157 does not fix it
- Argumented variants ("gluster vol geo-rep status <MASTER>", "gluster vol geo-rep status <MASTER> <SLAVE>") do work.
Comment 1 Anand Avati 2012-04-25 03:29:27 EDT
CHANGE: http://review.gluster.com/3215 (glusterd: glusterd_op_build_payload() fix for geo-rep) merged in master by Vijay Bellur (vijay@gluster.com)

Note You need to log in before you can comment on or make changes to this bug.