Bug 815613 - coverity fixage implicate geo-replicate brokage
coverity fixage implicate geo-replicate brokage
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-04-24 00:10 EDT by Csaba Henk
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:53:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Csaba Henk 2012-04-24 00:10:28 EDT
Description of problem:

geo-rep does not work... yet again

Version-Release number of selected component (if applicable):


How reproducible:

very much indeed!

Steps to Reproduce:
1. gluster vol geo-rep MASTER SLAVE start
2. gluster vol geo-rep MASTER SLAVE start
3. gluster vol geo-rep MASTER SLAVE start
  
Actual results:

<empty line>
geo-replication command failed
geo-replication start option validation failed
geo-replication command failed
geo-replication start option validation failed
geo-replication command failed

Expected results:

Starting geo-replication session between MASTER & SLAVE has been successful
geo-replication session between MASTER & SLAVE already started
geo-replication command failed
geo-replication session between MASTER & SLAVE already started
geo-replication command failed

Additional info:

Bisected to http://review.gluster.com/3145
Comment 1 Amar Tumballi 2012-04-24 00:30:49 EDT
http://review.gluster.com/#patch,sidebyside,3145,3,xlators/mgmt/glusterd/src/glusterd-geo-rep.c 

Csaba, let me know what should be the behavior when 'fd' and 'pfd' are -1, because the coverity was complaining of possible negative value passed to systemcall.
Comment 2 Anand Avati 2012-04-24 16:32:07 EDT
CHANGE: http://review.gluster.com/3219 (glusterd: command check failure fixes) merged in master by Anand Avati (avati@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.