Bug 815629 - DevIL: unconditional use of SSE3 instructions
DevIL: unconditional use of SSE3 instructions
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: DevIL (Show other bugs)
rawhide
i386 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 02:09 EDT by Daniel Scharrer
Modified: 2012-06-02 20:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-02 20:03:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Scharrer 2012-04-24 02:09:43 EDT
DevIL's 1.7.8 ./configure script enables SSE, SSE2 and SSE3 instructions if
supported by the compiler and unless such instructions are explicitly disabled
by --disable-sse3 etc. There is not run-time check for CPU support when using
these instructions - in fact it adds the -msse3 compiler option.

SSE3 is not universally supported in 32-bit x86 CPUs and using affected
functions such as ilConvertImage() may result in the application being
terminated with the SIGILL signal on such CPUs.

Re-building DevIL without SSE3 support fixes this bug - disabling SSE2 and SSE
should also be considered.

There is also an upstream DevIL bug report at
https://sourceforge.net/tracker/?func=detail&aid=3520344&group_id=4470&atid=104470

Additional info:
This bug is also found in many other Linux distributions' DevIL packages:
- Gentoo Linux (fixed): https://bugs.gentoo.org/show_bug.cgi?id=412791
- Debian (open since over a year)
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=572954
- Ubuntu (open): https://bugs.launchpad.net/ubuntu/+source/devil/+bug/987634
- openSUSE (open): https://bugzilla.novell.com/show_bug.cgi?id=758713
- Arch Linux (open): https://bugs.archlinux.org/task/29590
Comment 1 Hans de Goede 2012-05-16 10:32:30 EDT
Thanks for the bug report.

I'm currently preparing a fixed build, fixing this by not using SSE3 (x86_64) or any SSE (ix86).
Comment 2 Fedora Update System 2012-05-16 11:34:26 EDT
DevIL-1.7.8-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/DevIL-1.7.8-9.fc17
Comment 3 Fedora Update System 2012-05-17 18:59:07 EDT
Package DevIL-1.7.8-9.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing DevIL-1.7.8-9.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7994/DevIL-1.7.8-9.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-06-02 20:03:05 EDT
DevIL-1.7.8-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.