Bug 815699 - Can add duplicate sshkey value via rhc client.
Can add duplicate sshkey value via rhc client.
Status: CLOSED CANTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 05:53 EDT by yquan
Modified: 2015-05-14 21:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 18:54:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot1 (42.81 KB, image/png)
2012-05-08 04:17 EDT, Yujie Zhang
no flags Details

  None (edit)
Description yquan 2012-04-24 05:53:42 EDT
Description of problem:
It can add duplicate sshkey value using rhc client.

Version-Release number of selected component (if applicable):
devenv_1738
rhc-0.91.6-1.el6_2.noarch

How reproducible:
Always.

Steps to Reproduce:
1.Create the domain via rhc client.
2.Add a sshkey.
3.Add the same sshkey again.
  
Actual results:
It can add same sshkey successfully.

Expected results:
It should return proper message such as "You have already saved this public key with a different name. Provide a different key."
And the shouldn't add the sshkey successfully.
Additional info:
Comment 1 Yujie Zhang 2012-05-08 04:16:46 EDT
Tested this issue on devenv_1761, still can add the same sshkey uisng different name in CLI, this is not allowed on website. Details see in attachment.
Comment 2 Yujie Zhang 2012-05-08 04:17:09 EDT
Created attachment 582913 [details]
screenshot1
Comment 3 Clayton Coleman 2012-06-19 18:54:40 EDT
This is because the CLI is using the old broker API.  We can't fix this until we refactor the CLI to use the new REST API.  That's going to be one or more large stories.  Until then this is CANTFIX

Note You need to log in before you can comment on or make changes to this bug.