Bug 815722 - Missing HumanTask service.
Missing HumanTask service.
Status: CLOSED WONTFIX
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Build Process, JBPM - within SOA (Show other bugs)
5.3.0 GA
Unspecified Unspecified
high Severity high
: ER2
: 5.3.0 GA
Assigned To: Default User
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 07:16 EDT by Marek Baluch
Modified: 2012-06-19 10:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.3.0 GA
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-09 16:05:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Path for this issue. (14.57 MB, application/zip)
2012-04-26 03:04 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2012-04-24 07:16:24 EDT
Description of problem:

Human task client cannot connect to the Human Task service. The connection attempt is failing with connection refused. The main cause is that the Human Task Service is not deployed in the application server (jbpm-human-task.war).

Please note that deploying the war is not enough because there are also some missing jars. (e.g. trove4j-x.y.z.jar)


Steps to Reproduce:
1. Run the bpm5Processor quickstart.
Comment 4 Marek Baluch 2012-04-24 08:03:13 EDT
Looks like trove4j-x.y.z.jar is the only one needed.

Tried to deploy the WAR taken from (http://jawa05.englab.brq.redhat.com/candidate/BRMS-5.3.0-ER6/brms-p-5.3.0.BRMS-ER6-deployable.zip), and add the missing jar but I'm still seeing exceptions:

org.jbpm.process.workitem.wsht.CommandBasedWSHumanTaskHandler$AbortTaskResponseHandler cannot be cast to org.jbpm.task.service.TaskClientHandler$TaskSummaryResponseHandler

At this moment I'm not sure about the cause. It's possible I picked wrong version of the WAR.
Comment 5 Marek Baluch 2012-04-26 03:04:32 EDT
Created attachment 580380 [details]
Path for this issue.

Removing TestBlocker tag. 

Tom provided me with a patch which makes it possible to resume test development and testing.

Patch attached.
Comment 6 tcunning 2012-05-09 16:05:28 EDT
The jbpm5 / esb integration will now require BRMS to be installed on top of SOA-P, so the Human Task WAR is no longer required within ESB or SOA-P - it will be provided in the bits that are installed from BRMS.  

Closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.